2

Problem Backgroud:

Our company has an IBM System X3200 M3 server running Windows Server 2008 R2 Enterprise with two WS Caviar Black 1TB HD in RAID 1.

Recently we had a power failure that corrupted the system boot, and since the previous IT guy didn't implemented any backup routines, it has fallen upon me to restore it.

After several error log analysis, I could isolate the problem: two system files (msahci.sys and bootcat.cache) went missing, causing some blue screens. I've entered the WinRE and copied the files from the original installation ISO (the version was right, I doubled-checked it), and after a fresh restart and a chkdsk, Windows was up and running again, but with one problem: I can't use the keyboard, it's disabled only after login screen shows up. Ethernet interfaces are disabled as well, but the mouse works just fine! Everything works (mouse, network interface, keyboard) before it: in CMOS setup, WinRE, console terminal... And for that reason I can't log in to diagnose further issues, because I can't press CTRL+ALT+DEL.

... so, why not just back it all up and format?

The first reason being it seems like that course of action will take a lot of extra time than finding a solution for this, there's more. We're a hardware development company, and there is a very specific custom firmware development IDE installed on that, that needs to generate a dump from it's schema files so it can be imported back after its re installation. Just saving its internal files and trying to copy it all back on installation folder has a historic of corrupting the schemas and losing data. There's a backup of those files but they are one month outdated and my supervisor is insisting in making the server work again (if only I'd been here sooner...)

Things I've tried so far:

  • Loaded setup defaults, only changing IO mode from IDE native to AHCI (otherwise it won't boot).
  • After doing a backup, I've copied and replaced every *.sys file inside C:\Windows\System32\drivers. No avail. Restored the backup.
  • Changed USB ports. Nothing.
  • Changed keyboard. Nothing.
  • Verified legacy support on BIOS. There isn't even such thing there.
  • Waited over 1:30h for supposed new hardware found, installing drivers case. Nothing.
  • Tried to load drivers from WinRE, with official driver (I'm currently trying with its original IBM keyboard, since the mouse is also the server's original and it works fine). Not even a blink from NumLock's LED.
  • I use a KVM and also tried to use both mouse and keyboard outside it. Nada.
  • Spent the last hour in Server Fault's similar questions. Either they're unanswered, or the answer didn't provide me a solution.
  • Already tried the following F8 menu options: Safe Mode, Safe mode with Network, Load Unsigned Drivers, Last Known Good Configurations, Repair your system.

Please, if anybody spots something that I've might missed for chance, or any thoughts that didn't occurred to me, share it! I'd really appreciate any kind of help.

If I forgot to provide any other information please ask and I'll edit the question.

PS: if I can't get an answer in 2 days that helps me troubleshoot it, I'll set a bounty.

  • 1
    Does this boot into safe mode? Or last known good config? – Nixphoe Oct 23 '15 at 18:48
  • @Nixphoe well pointed, I've actually tried this, already, with no results. I'll update the question. – Alan Machado Oct 23 '15 at 18:48
  • 1
    Have you tried plugging two keyboards in at the same time? – Andrew Morton Oct 23 '15 at 20:09
  • 1
    Oh, I take it you are working on a clone of the disk drive(s). Can you connect to the server with RDP? Also, and assuming you are working on a cloned drive, you can use ~some sort of Linux boot disc~ to edit the registry and disable the ctrl-alt-del requirement, and also remove the password. How to Enable or Disable Secure Log On CTRL+ALT+DELETE in Windows 7 has a downloadable file with the registry settings. – Andrew Morton Oct 23 '15 at 20:29
  • 1
    Maybe you can summon the On Screen Keyboard? – Max Oct 27 '15 at 15:27
0

Turned out it was a very strange problem, but I was able to reproduce. The MMC, running Task Scheduler snap in, was executing a task where it should run a batch file to clean up a shared file transfer directory. The power failure broke in while it was running, and for some reason the Security Catalog (C:\Windows\System32\catroot2) got corrupt. It seems it has a large chain of dependencies, and when Windows tried to restore things the first time, it swept out some drivers and crucial boot files (it erased even BOOTMGR and the Boot hidden folder from C:).

I made peace with the fact that I was facing a formatting situation, but I decided to take a last shot. I made a backup of the whole C: drive, as it was, and reinstalled Windows 2008 again, from scratch. Then I just restored some files (system and non-system), enough to make the said IDE running as nothing happened. At reboot, I've got a "BOOTMGR missing" warning, but then the Repair Your Computer menu from CD installation solved the issue with a bootrec /fixmbr && bootrec /rebuildbdc && bootrec /fixboot, and everything is fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.