1

We have 10+ VPS's running Windows Server (mostly 2012R2). All these servers have both a public and private network interface, with the private network including a pfsense VPS that builds a VPN connection to our office. All servers have a (persistent) route, making the pfSense's ip the gateway for our offices subnet.

The problem

This has been working mostly fine for months, but we have had two cases where a server stops being able to access or be accessed from the office subnet. Ping works, though. Also, all services in its own subnet are still reachable and work fine.

The first case was "solved" by reinstalling, but that obviously isn't an ideal or scalable solution.

Setup

All Windows Servers are domain joined, and have the local (vps) and remote (office) domain controller set as DNS servers on both adapters.

The public connection gets its ip address from the providers DHCP server, the private connection has a static ip in the 192.168.16.0/24 range with matching net mask and no gateway.

What I have tried

  • removed and reinstalled the network adapters through the device manager;
  • re-configured the route multiple times, using route, netsh and the PowerShell networking commands;
  • disabled the public interface, and reconfigured the private interface with the VPN VPS' ip as gateway;
  • changed the static, private ip;
  • disabled the firewall entirely;
  • disabled IPv6;
  • removed all isatap adapters

It's hard to trace the issue back to a specific change, as I am not the only admin responsible for the day to day operation of the servers, and issue might have been introduced a while before we discovered it, as the servers is generally used over its public interface.

I really have no clue what this could be anymore, so I hope someone has a better idea of where this might have gone wrong.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.