-2

I'm having trouble using my nc command. Everytime I enter any parameter, even using -h, linux just prints:

*BusyBox v1.20.2 (2014-05-14 13:19:21 EDT) multi-call binary.

Usage: nc [IPADDR PORT]*

I am able to type nc localhost 22 which produces

*SSH-2.0-OpenSSH_6.6*

Not to sure what's going on...

4
  • 1
    It seems to be working. What is the problem you are having? Oct 26, 2015 at 19:04
  • What do you expect it should output?
    – Jakuje
    Oct 26, 2015 at 19:16
  • I want to be able to use options such as -l listen and -D for debug etc... But everytime i feed in a option it won't allow it. Because it says Usage: nc [IPADDR PORT] I essentially want to be able to use parameters with nc. Do I have to install additional packages? or change a configuration file for this?
    – sphchow
    Oct 26, 2015 at 19:17
  • I'm trying to set up udp in a ssh tunnel using this tutorial: link At one point i need to use the nc command in such a way as: local# sudo nc -l -u -p 53 < /tmp/fifo | nc localhost 6667 > /tmp/fifo but my nc doesn't allow parameters...
    – sphchow
    Oct 26, 2015 at 19:18

2 Answers 2

2

You are most likely working on an embedded system where many tools are only available in a limited form in the form of busybox. This tool collection only offer the most essential features, and it's entirely possible the nc features you want are not available.

Modern OpenSSH versions don't need nc for a tunnel. Look into the -W parameter.

Adapted from my ~/.ssh/config files:

Host  *.example.com !gateway.example.com
   ProxyCommand ssh -q -A  -x gateway.example.com -W %h:%p
   IdentityFile ~/.ssh/id_rsa

Not sure if this works for your specific case though.

12
  • Is there a way to include more features to a tool in this case?
    – sphchow
    Oct 26, 2015 at 19:23
  • @sphchow: Depends on your environment. See my edit for a better way to create a tunnel.
    – Sven
    Oct 26, 2015 at 19:26
  • The reason I need to do it with nc is because it lets me setup TCP to UDP forward on my server. So I don't think your way to create a tunnel will work for my purpose? I'm not an expert so I definitely could be missing something.
    – sphchow
    Oct 26, 2015 at 19:30
  • Sorry, I didn't saw the UDP part and I am not sure it will work right, I use this for a SSH gateway host.
    – Sven
    Oct 26, 2015 at 19:31
  • @sphchow Why are you trying to do any of this at all? Oct 26, 2015 at 19:32
1

It appears that your version of busybox nc has been compiled without listening capability. There is a compile time option NC_SERVER that has to be set to get the capabilities you want. The messages and functionality ou are seeing are entirely consistent with this being not set.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .