2

I’m trying to get some data from an IBM server, for example the temperature using the OID .1.3.6.1.4.1.2.3.51.3.1.1.2.1.1

If I run the command:

snmpget -O n -v 2c -c public IP .1.3.6.1.4.1.2.3.51.3.1.1.2.1.1

I get the answer:

no such object available on this agent at this oid

I also used the plugin check_snmp_ibm_imm with this command

./check_snmp_ibm_imm.sh -H IP -C public -T health

but I get

Timeout: No response from IP

I read that I need the MIB file of my server, then I installed the IBM System Director on the server so that I found some MIB files in the C:\Program Files (x86)\IBM\Director\proddata\snmp\uim directory. How do I use then these MIB files? I have already put them in the directory /usr/share/snmp/mibs of my monitoring server.

Thank you very much

  • I'd say since you're getting Timeout: No response from IP you don't have SNMP setup correctly on the server. MIB files will only translate the OID information, so if you're not getting your OID information from the server, I'd start looking at SNMP on the IBM server. – Nixphoe Oct 27 '15 at 13:35
  • Hi Nix, I forgot to say that the SNMP is working on the server. Indeed if I run the command: snmpwalk -v 2c -c public IP I get the right answer. – FabriC Oct 27 '15 at 13:40
  • I'd check your OID documentation again and double check that you have the correct one. Where did you find it? – Nixphoe Oct 28 '15 at 13:04
  • I saw how some OIDs has been created in the plugin check_snmp_ibm_imm (on Nagios exchange). I saw that .1.3.6.1.4.1.2.3.51.3.1.1.2.1.1 is one of these OIDs and I tried to see if it worked. I thought that the plug-in could work with every kind of IMM (my IBM server is an X3650 M2). – FabriC Oct 29 '15 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.