1

I have a HP Proliant ML150 server with a scsi raid controller installed. Two disks are configured in RAID 1. My problem is when i start my computer, in the beginning, a message appears that the array is failed. This problem has occurred after a normal reboot.

I would like to recover my data from the disks.

I've tried to boot on a external CD (Clonezilla, system rescue cd, hiren's boot cd, etc) but it's impossible to get any data from disks. Clonezilla is recognizing an array but when i want to start the copy, the message "no input device" appears and then Clonezilla ask me to restart the process, power off or reboot the system.

I also noticed, when i start my computer, there are green lights on the front on hard drive and when i boot on a CD, the green lights are changing to red lights. Seems like a process is locking/disconnecting my hard drives.

I have looked for an option in my bios to force online disks when there is a failed array, but it doesn't exists. Also in the Array Utility, i've checked and fixed disks for any bad sectors.

What should i do to recover my data ? Many thanks for your help !

0

Because it is RAID 1 you should be able to pull the disks, put them in a different server/workstation with a regular IO controller and treat them as regular disks rather than an array. Each disk should be the same unless the array got messed up. There could be something else going on, but it's a good place to start with restoring your data. It sounds a bit like your controller might be malfunctioning.

  • Bad news...I've tried but same thing : can't access on data. I don't find any other solution than sending my disk to an external compagny – user2156353 Oct 29 '15 at 10:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.