I have installed ZFS(0.6.5) in my Centos 7 and I have also created a zpool, everything works fine apart from the fact that my datasets disappear on reboot.
I have been trying to debug this issue with the help of various online resources and blogs but couldn't get the desired result.
After reboot, when I issue the zfs list command I get "no datasets available" , and zpool list gives "no pools available" After doing a lot of online research, I could make it work by manually importing the cache file using zpool import -c cachefile, but still I had to run zpool set cachefile=/etc/zfs/zpool.cache Pool before the reboot so as to import it later on after reboot.

This is what systemctl status zfs-import-cache looks like,

zfs-import-cache.service - Import ZFS pools by cache file Loaded: loaded (/usr/lib/systemd/system/zfs-import-cache.service; static) Active: inactive (dead)

cat /etc/sysconfig/zfs

# ZoL userland configuration.

# Run `zfs mount -a` during system start?

# Run `zfs unmount -a` during system stop?

# Run `zfs share -a` during system start?
# nb: The shareiscsi, sharenfs, and sharesmb dataset properties.

# Run `zfs unshare -a` during system stop?

# Specify specific path(s) to look for device nodes and/or links for the
# pool import(s). See zpool(8) for more information about this variable.
# It supersedes the old USE_DISK_BY_ID which indicated that it would only
# try '/dev/disk/by-id'.
# The old variable will still work in the code, but is deprecated.

# Should the datasets be mounted verbosely?
# A mount counter will be used when mounting if set to 'yes'.

# Should we allow overlay mounts?
# This is standard in Linux, but not ZFS which comes from Solaris where this
# is not allowed).

# Any additional option to the 'zfs mount' command line?
# Include '-o' for each option wanted.

# Build kernel modules with the --enable-debug switch?
# Only applicable for Debian GNU/Linux {dkms,initramfs}.

# Build kernel modules with the --enable-debug-dmu-tx switch?
# Only applicable for Debian GNU/Linux {dkms,initramfs}.

# Keep debugging symbols in kernel modules?
# Only applicable for Debian GNU/Linux {dkms,initramfs}.

# Wait for this many seconds in the initrd pre_mountroot?
# This delays startup and should be '0' on most systems.
# Only applicable for Debian GNU/Linux {dkms,initramfs}.

# Wait for this many seconds in the initrd mountroot?
# This delays startup and should be '0' on most systems. This might help on
# systems which have their ZFS root on a USB disk that takes just a little
# longer to be available
# Only applicable for Debian GNU/Linux {dkms,initramfs}.

# List of additional datasets to mount after the root dataset is mounted?
# The init script will use the mountpoint specified in the 'mountpoint'
# property value in the dataset to determine where it should be mounted.
# This is a space separated list, and will be mounted in the order specified,
# so if one filesystem depends on a previous mountpoint, make sure to put
# them in the right order.
# It is not necessary to add filesystems below the root fs here. It is
# taken care of by the initrd script automatically. These are only for
# additional filesystems needed. Such as /opt, /usr/local which is not
# located under the root fs.
# Example: If root FS is 'rpool/ROOT/rootfs', this would make sense.

# List of pools that should NOT be imported at boot?
# This is a space separated list.

# Optional arguments for the ZFS Event Daemon (ZED).
# See zed(8) for more information on available options.

I am not sure if this is a known issue,.. if yes, Is there any workaround for this? perhaps an easy way to preserve my datasets after reboot and preferably without the overhead of an cache file.

  • what zpool status -v and zpool import says?
    – ostendali
    Oct 28 '15 at 10:28
  • Hi, zpool status -v zpool status -v no pools available And, zpool import gives me this pool: zfsPool id: 10064980395446559551 state: ONLINE action: The pool can be imported using its name or numeric identifier. config: zfsPool ONLINE sda4 ONLINE Oct 28 '15 at 10:39
  • zfs import is how I could make it work, by setting the cachefile initially using the set cachefile command Oct 28 '15 at 10:40
  • you missed /etc/init/zpool-import.conf, can you post the content of that file as well?
    – ostendali
    Oct 28 '15 at 11:19
  • 1
    Is the ZFS target enabled? systemctl status zfs.target Oct 28 '15 at 12:44

Please make sure the zfs service (target) is enabled. That's what handles pool import/export on boot/shutdown.

zfs.target loaded active active ZFS startup target

You should never have to struggle with this. If you have a chance, run an update on your zfs distribution, as I know the startups services have improved over the last few releases:

[root@zfs2 ~]# rpm -qi zfs
Name        : zfs
Version     :
Release     : 1.el7.centos
  • Hi, I had tested as well which happens to be the latest release I believe, but still faced this issue, with .6.5.3 I had to even run modprobe zfs everytime I did a reboot to load the modules. Btw, Target is not enabled please check the output in comments above(reply to Michael). May I know how to set one ? thanks. Oct 28 '15 at 13:02
  • All you need to do is probably something like: systemctl enable zfs.target
    – ewwhite
    Oct 28 '15 at 13:19

ok, so the pool is there, which means the problem is with your zfs.cache, it is not persistent and that is why it looses its config when your reboot. what I'd suggest to do is to run:

      zpool import zfsPool 
      zpool list 

And check if the if it is available. Reboot the server and see if it comes back, if it doesn't then perform the same steps and run:

      zpool scrub

Just to make sure everything is alright with your pool etc.

Pls also post the content of:


Alternatively, if you are looking for workaround to this issue you can set it of course as follow.

Change the value in from 1 to 0:


and add the following to your /etc/rc.local:

    zfs mount -a

That will do the trick.

  • I ran zfs import zfsPool which as expected imported my pool, then I did a reboot, ran zfs list which gave me no datasets. I repeated the steps again and ran zfs scrub which did not give me any output, I did a reboot now again, and still the datasets are not preserved Oct 28 '15 at 11:00
  • in case you haven't seen my request, I will post again "can you also post what is in /etc/default/zfs?"
    – ostendali
    Oct 28 '15 at 11:02

I also had the problem of the zfs disappearing after a reboot. Running CentOS 7.3 and ZFS Reimporting brought it back (zpool import zfspool) only until the next reboot.

Here's the command that worked for me (to make it persist through reboots):

systemctl preset zfs-import-cache zfs-import-scan zfs-mount zfs-share zfs-zed zfs.target

(Found this at: https://github.com/zfsonlinux/zfs/wiki/RHEL-%26-CentOS )


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.