I have installed CentOS 7 x64 on VMware workstation 12.0, I built wordpress website on it and then after my colleague finished his decorative work, I used VMware vCenter Converter Standalone Client 6.0 to move it to an ESXi 5.5 host. Since I moved it, the server is most of the time losing network connectivity. When I ping it, I get request timed out. I have to keep turning the NIC off/on to retain connectivity. When I open the website, I get a white empty page. I am unable to SSH the server as well.

I have many other servers that I installed on ESXi 5.5 since the very first moment, contrary to this server which I built on workstation 12.0 then moved it to ESXi 5.5. The VM machine version is 8.0, if I remember it rightly.

I removed the network card from the machine, deleted NIC file from network-scripts directory, rebooted the machine, added a new NIC, still the same issue. How can I troubleshoot such issues? Any clues on what's going on with this server.

  • Are VMware tools installed in the VM?
    – joeqwerty
    Commented Oct 28, 2015 at 20:56
  • The VM version is 8, if I remember correctly, can you confirm?
    – GregL
    Commented Oct 28, 2015 at 21:16

2 Answers 2


If the NIC works at all, I would rule out driver, or at least put it lower on the list.

Next, you could be looking at hardware problems, but in a virtual environment, one bad NIC should affect all virtual machines connected to the NIC.

With intermittent connectivity, the best place to start is verify that you don't have a duplicate IP address on the network already.

One method is to shut down your cloned box and see if you can probe its IP on the network using a tool such as nmap.

nmap <ip_address>

If nothing is returned, nmap has some options you can use like -Pn, -sN and -sS that might allow you to see what a local firewall might otherwise be preventing you from seeing.

If you are on a corporate network that has a DHCP server, managed network switches or a hardware appliance firewall, you can look at each of those as well to see if the IP address you want to use is being used by two different devices - typically by showing two different mac addresses on a single IP.

  • It is version 8 on ESXi
    – elekgeek
    Commented Oct 28, 2015 at 21:57
  • There is no IP addresses conflict. I am sorry, by intermittent I meant it works for a few minutes, then stops working. I have to turn NIC off/on to retain network connectivity. During the time the problem occurs, I can ping, but not the gateway of the vlan. Strange thing I have a server already working on the same vlan..!
    – elekgeek
    Commented Oct 28, 2015 at 22:09
  • BTW, VMWare tools are not installed. I 've never had to install them on any server any way.
    – elekgeek
    Commented Oct 29, 2015 at 7:44
  • As a test, plug two computers together into a different switch, but disconnect that switch from your network so that these two computers can only talk to each other. If your computer stays online during this test, the problem is not your CentOS 7 install.
    – Jim
    Commented Oct 29, 2015 at 20:09
  • Actually, I don't really have to do this. My install is just OK, this is not my first server of this type, the settings are simply similar to other already running servers on the same host on the same vSwitch, others are running just fine. When I ping the loopback interface i.e. I get a constant reply which means my TCP/IP stack is just OK. As long as the interface works and few minutes later disconnects and I have to turn it off/on then it appears to be a problem in ESXi itself.
    – elekgeek
    Commented Oct 30, 2015 at 9:47

Here is the thing:

I managed to solve this issue by installing Update 2 for ESXI v5.5, all is smooth now, the update has updated drivers as well. I installed a new machine then left it for the night long to see if it's network gets disconnected.

Unfortunately, I could not get the machine that was converted to work without the network problems, tried installing vmware tools, open-vm-tools, nothing. I had to install a new machine to get things working. I am lucky it was a single unimportant machine!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .