0

I am trying to install Gluster 3.7.5 on Amazon Linux AMI but cannot get passed error

Error: Package: glusterfs-libs-3.7.5-1.el7.x86_64 (glusterfs-epel)
           Requires: rsyslog-mmjsonparse
Error: Package: glusterfs-3.7.5-1.el7.x86_64 (glusterfs-epel)
           Requires: systemd-units

I cannot find the rpm or needed libraries to get rsyslog-mmjsonparse installed.

Does anyone know how to get passed this?

0

rsyslog-mmjsonparse is part of the base repository for RHEL-7 and CentOS-7. If you use Amazon Linux, verify that it is based on el7 too. If not, you should probably install the el6 version of the Gluster packages from http://download.gluster.org/pub/gluster/glusterfs/3.7/LATEST/EPEL.repo/epel-6/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.