0

I'm stuck trying to get squidguard to run. It's due to the version of berkelydb ( libdb ).

This is a fresh Debian jessie server install. No gui, just ssh, build-essential etc.

Installed squid from source. No problem.

Tried to install squidgaurd from apt. Wanted to install squid3, so no. Installed squidguard from source. Didnt work. Realized wrong user. Re compiled with correct user. Got no errors.

Configured squidguard. Went to test config with squidguard -d and got this:

2015-10-29 18:41:10 [10707] New setting: dbhome: /usr/local/squidGuard/db
2015-10-29 18:41:10 [10707] New setting: logdir: /usr/local/squidGuard/log
BDB1565 DB->put: method not permitted before handle's open method
2015-10-29 18:41:10 [10707] sgDbUpdate: put: Invalid argument
2015-10-29 18:41:10 [10707] Going into emergency mode

Googled a bit. Saw there was an issue with 1.4 having issues with anything later than 4.6 of berkelydb.

Found the .deb for libdb4.6. Installed. Same failure. Recompiled with --with-db pointed to /usr/lib/libdb-4.6.so - Same failure Recompiled with --with-db-lib pointed to /usr/lib/libdb-4.6.so - Same failure Tried both again without the .so file name. Same failure.

Next I thought maybe I missed something. So I found the squeeze backport repository and tried to reinstall libdb4.6 from there.

Reinstallation of libdb4.6 is not possible, it cannot be downloaded.
Reinstallation of libdb-dev is not possible, it cannot be downloaded.

At this point I've reached the end of my linux skills. I've tried every combination of search and haven't found much.

I was going to try mysql support but from what I saw it's only for authentication.

I'd either like:

To fix this and get it working
Find something other than squidguard that can do blacklists.
  • Why are you using Debian? – Michael Hampton Oct 30 '15 at 14:18
  • 1
    Does it matter? Mostly because that's what I've been using for 10 years or so. – TheEditor Oct 30 '15 at 14:21
1

I know it's been a long time since the question, but I was struggling with the same problem.

To solve I did the following:

Download BerkeleyDB and compiled it from source.

tar -xzvf db-4.6.21.tar.gz

cd db-4.6.21

cd build_unix/

../dist/configure --prefix=/usr/local/berkeleydb

make

make install

echo "/usr/local/berkeleydb/lib/" >> /etc/ld.so.conf

ldconfig

Compile SquidGuard again:

./configure  --with-db=/usr/local/berkeleydb

Check it:

squidGuard -v

SquidGuard: 1.4 Berkeley DB 4.6.21: (September 27, 2007)

squidGuard -d

2018-09-04 23:00:47 [7581] New setting: dbhome: /usr/local/squidGuard/db
2018-09-04 23:00:47 [7581] New setting: logdir: /usr/local/squidGuard/log
2018-09-04 23:01:01 [7581] squidGuard 1.4 started (1536112847.496)
2018-09-04 23:01:01 [7581] squidGuard ready for requests (1536112861.611)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.