-2

I have an ESXi 6.0 host on which I experience very weird networking performance. When I download a 1000mb .bin file using wget, the speed is fine for the first ±4 seconds: 14MB/s. This is the maximum speed of my ISP. After those first seconds the speed drops to approximately 5MB/s, and sometimes even further.

I have configured a virtual switch, which is connected to my NIC: a HP 380t which is supported by ESXi. I also tried injecting the drivers for my onboard Realtek, but this gives me the same results. I tried all three available virtual NICS: vmxnet 2 and 3, and the e1000. The latest VMWare tools are installed. MTU's are all default for now: 1500.

I tried multiple VM's:

  • Ubuntu 14.04
  • Ubuntu 12.04
  • CentOS 7
  • Debian 8.2

These VM's are installed on a somewhat older SSD. I benchmarked it using hdparm, and got 123MB/s.

Other things I have tried are disabling the firewall (ufw in Ubuntu), and disabling IPv6, all to no avail.

I run the host on a Asus M5A97 R2.0 with a FX-6300 and 16GB of ECC RAM. If I need to run any other benchmarks to find out why this problem occurs, I'm happy to help.

closed as off-topic by Chopper3, Ward, mdpc, colealtdelete, MadHatter supports Monica Nov 2 '15 at 8:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on Server Fault must be about managing information technology systems in a business environment. Home and end-user computing questions may be asked on Super User, and questions about development, testing and development tools may be asked on Stack Overflow." – Chopper3, Ward, colealtdelete, MadHatter supports Monica
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Do you get the same performance issues when downloading large files from other sites? (go try downloading some Linux ISOs from different sites) What about if you try to transfer a large file locally (same subnet). Try different network scenarios to try and narrow down the list of possible culprits. – Safado Oct 30 '15 at 14:54
  • I tried getting some 100 and 1000mb.bin files from other mirrors, same results. With your advice I tried downloading the Debian image from my ESXi host using scp, and it starts with ±30MB/s. After a few seconds it starts going down, and after about a minute it stays at 9MB/s. – Ashwin van Dijk Oct 30 '15 at 15:02
  • If all VMs have the same issue downloading files from the Internet, maybe the problem isn't with the VMs. Do transfers over the LAN perform differently? – GregL Oct 30 '15 at 15:13
  • I tried downloading the same files (from the same mirror) on my Mac, and that works fine. It is connected to the same network. Even when I download the files using the ssh-shell of my ESXi host, the performance is great. – Ashwin van Dijk Oct 30 '15 at 15:16
2

The only way to get to the bottom of this is to get files from another local machine - ideally one with a consistent transfer capability such as a physical box using a RAM disk as it's data store. If you can transfer from that, rather than from the internet which is wildly inconsistent, and still see the problem then I suggest you have a VM contention issue coming from either CPU or storage - at least these will be easy to isolate.

Also serverfault is a site for professional sysadmins, inherently we try to stick to completely supported product sets for stability and your system really doesn't fall into that category.

  • Since the speed on the host itself is fine, I don't think we can file this problem under "hardware". Also, if I transfer a file from the ESXi host to a VM, I see the same problem. To me it seems like a configuration-issue in ESXi... – Ashwin van Dijk Oct 30 '15 at 15:49
  • 1
    How do you mean 'from the ESXi host to the VM'? the ESXi service console isn't a general purpose OS and shouldn't be treated as one - ideally you shouldn't ever really need to use it directly, only via the web client tools – Chopper3 Oct 30 '15 at 16:26
  • I know it isn't a "general purpose OS", but it's a way to check if the hardware to my host is okay. Which it is, since I don't see the drops in speed there, but only between the host and one of the VM's. – Ashwin van Dijk Oct 30 '15 at 19:19
  • But transferring between a VM and the host is NOT a predictable method to measure this. – Chopper3 Oct 30 '15 at 19:51
  • How about transferring from the internet to the ESXi host? In my opinion if I get right speeds there, without drops, the hardware itself is fine.. – Ashwin van Dijk Oct 30 '15 at 19:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.