4

All the PC's on my network are having trouble accessing a certain website (https://frontapp.com/) we need. The main page of the site will load partially, but the text and page will look strange. The 'sign in' page will not load at all, just give a connection error. The issue is not with the site because it loads on my home and mobile internet fine. I believe it is some sort of DNS issue because the VM that has the DNS server can access the internet and the site just fine.

Our network structure:

  • We have a Netgear DEVG2020 as our ADSL modem and a Asus N66U as a wireless AP.
  • A server with 2x VM's running Server 2012R2.
  • One VM handles our accounting program and print server
  • The other is running Active Directory, DHCP and DNS. The AD server's internet is fine and will load the site in question with no problems.
  • 4 PC's running Windows 7 (x86). One of these pc's is able to intermittently connect to the website, seemingly randomly. None of these pc's are connected to the active directory/domain. There are no differences in configuration in these pcs.

When the PC's are connected directly via ethernet cable to the router, they are able to connect to Front and their internet is fine.

This issue has only appeared a few days ago. Tech support from the internet company said it was on our end. Replacing the router/modem doesnt appear to be a possibility: our phones are VOIP and I believe that the phones are tied into the modem so we cant use our own hardware. Also we are in an isolated area, getting a tech support or a new modem would be difficult.

I've tried:

  • Uninstalling and reinstalling the DNS role, deleting DNS cache.
  • Flushing DNS on all pc's
  • netsh int ip reset c:\resetlog.txt and netsh winsock reset
  • Setting the DHCP to have the devg2020 as the only dns server on the network and giving everyone new IP's.
  • Restarting everything
  • connecting the devg2020 directly to a PC. This works fine, leading me to believe it has something to do with DNS.
  • Ping and tracert to frontapp. Get nothing, tracert doesnt even show the router.
  • nslookup on the pcs that cant access it. they get the same result as the DNS server.
  • Took a look at the traffic on one of the pcs with wireshark. Honestly not sure what I'm looking for.

I'd really appreciate any help.

edit: interestingly this morning it worked on some computers this morning. By afternoon, only 2 pc's were able to access it. I cant work it out.

  • Can you load the site (when it's not working) with chrome, F12, console tab, F5(refresh) and see what resources do not load? – Jacob Evans Nov 1 '15 at 0:24
1

I think I figured it out. I had the router that was used as a Access Point for the wifi put in as a Router in the DHCP server and I believe clients were trying to connect to the internet through it.

I removed it as a router in the DHCP server and everything works now, so fingers crossed.

0

EDIT: Just saw your Wireshark comment... If you capture the traffic traffic when it does work and capture the traffic when it does not work and compare the two, this may give you a clue. I'd think the Wireshark trace files when it does not work will show something.

This sounds like some sort of Internet content filtering or something with the network or some device setting filtering the TCP/IP Internet traffic on your PCs that have this issue with everything you explain.

I'd check the management interface of the Asus N66U and see if it has some sort of filtering or content filtering to the IP addresses it allows out it's interface. You bypass that thing and you say it works.

I assume the DC it works from is wired where the others go wireless through the AP and there's something there causing this. Your ISP already confirmed on their side too they see no issues.

Perhaps it's filtering some SSL/TLS certificate chain/path for the URL above and that's why it loads initially until you go to sign in option?

Compare the way it works and doesn't work with how it routes it's network traffic (from point to point to point, etc) to get to the Internet. Check each device in the loop that's not otherwise when it does work in case it has some filtering feature or function, TCP/IP, DNS settings, etc. you need to adjust.

Check ALL the TCP/IP address settings assigned to the PCs when they do and do not work too and compare all the settings to see if there's difference here.

Do the non-domain joined PCs get the same IP settings when connected to the wire versus the AP point and see what's different there.

Run some NSLOOKUP commands and compare those results when it does or does not work or change LSERVER to Google's 8.8.8.8 and see if there's any difference using it or not.

Start with the simple stuff and see if that gets you anywhere closer.

  • I actually removed the N66U and see if that made a difference and it didnt make any difference. I'll take a look at the wireshark tomorrow. All the TC IP settings ate the same. – user2757902 Nov 1 '15 at 0:20
  • When you say When the PC's are connected directly via ethernet cable to the router, they are able to connect to Front and their internet is fine., what device are they connected to and what are they bypassing? If it works from here but not the other way, then I'm just wondering what features and functions of the network devices they'd go through (hops) otherwise may be blocking something.If it was web browser related, then this should not make a difference if you're doing it from the same PC with the same browser. Also, wonder if the site could have had issues when your PCs did? @user2757902 – Pimp Juice IT Nov 1 '15 at 13:22
  • @user2757902 Another way to test whether or not it may be DNS it to set a PC with the issue to get the IP address via DHCP but hard code the Google DNS servers for the DNS servers in TCP/IP properties... then try getting to the site or have the end user use it for a while and tell you if the problem pops up... You could use 8.8.8.8 as primary and 8.8.4.4 as secondary DNS addresses. Trying to think of some other simple methods to test with. Lastly, are there any firewall appliances or DNS filtering systems setup elsewhere in your setup? – Pimp Juice IT Nov 1 '15 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.