2

I've just installed and configured OpenDKIM to use it with Postfix and Dovecot on my server. I can send e-mails to another accounts, but when I check the header I find this:

dkim=temperror (no key for signature)

Here is the most important configuration I made (in fact, I followed this tutorial from DigitalOcean). My server is running Ubuntu 14.04 (x86).

In fact, how can I correct that error? (The line tells me that the mail isn't verified).


File: /etc/opendkim.conf (fragment)

AutoRestart             Yes
AutoRestartRate         10/1h
UMask                   002
Syslog                  yes
SyslogSuccess           Yes
LogWhy                  Yes

Canonicalization        relaxed/simple

ExternalIgnoreList      refile:/etc/opendkim/TrustedHosts
InternalHosts           refile:/etc/opendkim/TrustedHosts
KeyTable                refile:/etc/opendkim/KeyTable
SigningTable            refile:/etc/opendkim/SigningTable

Mode                    sv
PidFile                 /var/run/opendkim/opendkim.pid
SignatureAlgorithm      rsa-sha256

UserID                  opendkim:opendkim

Socket                  inet:12301@localhost

File: /etc/opendkim/TrustedHosts

127.0.0.1
localhost
192.168.0.1/24
*.fjweb.club

File: /etc/opendkim/KeyTable

1115._domainkey.fjweb.club fjweb.club:1115:/etc/opendkim/keys/fjweb.club/1115.private

File: /etc/opendkim/SigningTable

*@fjweb.club 1115._domainkey.fjweb.club

File: /etc/default/opendkim

SOCKET="inet:12301@localhost"

File: /etc/postfix/main.cf

milter_protocol = 2
milter_default_action = accept
smtpd_milters = inet:localhost:12301
non_smtpd_milters = inet:localhost:12301
0

I finally found the problem, and may be silly, but I'll leave it here so anyone can check this first:

Remember to double-check not to add the domain next to the host value of the TXT record

What I mean is this: OpenDKIM needs a TXT record (check DNS settings for the domain you have) to succesfully sign e-mails. Check the "Name" (or "host") column of it: that sould be default._domainkey and not default._domainkey.yourdomain.bla!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.