-1

This morning our Exchange 2013 server stopped sending emails because the hard drive was full.

We have just over 290GB of Exchange log files. How can I go about clearing up these log files?

So far I have tried -

gci ‘C:\Program Files\Microsoft\Exchange Server\V15\Logging’,'C:\inetpub\logs’ -Directory | gci -Include ‘.log’,'.blg’ -Recurse | ? LastWriteTime -lt (Get-Date).AddDays(-30) | Remove-Item

This cleared about 2GB but we need to clear more space.

Thanks

  • 1
    I'm trying to not assume things. You've done a full backup already? 290GB of log files is massive, so I'm guessing backups aren't getting done. – TheCleaner Nov 4 '15 at 14:06
  • How can I go about clearing up these log files? - Backup the mailbox database(s) with an Exchange aware backup program that can flush the transaction logs when the backup completes. You can use Windows Server Backup for this if need be. – joeqwerty Nov 4 '15 at 16:27
  • Backups are being done, however I believe it isn't set to flush the logs. – dynamicuser Nov 5 '15 at 10:39
0

Use wbadmin with parameter -vssfull. If wbadmin is not there, add the backup role.

Note: The default behavior of WSB is to perform a VSS Copy Backup, which will not truncate the logs. To configure a VSS Full Backup you must configure a Custom backup (not Full Server), add the volumes that contain the Exchange data, click Advanced Settings, and select VSS Full Backup on the VSS Settings tab

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.