2

I've experienced issue when installing nagios on VM (Centos 6) I followed steps described in http://www.tecmint.com/install-nagios-in-linux/ Everything was fine untill

[root@tecmint ]# service nagios start

After trying to start nagios I got only this :

[root@Cogythos nagios]# service nagios start

Starting nagios (via systemctl):

Nothing more has happened. Service status:

[root@Cogythos nagios]# service  nagios status -l nagios.service - LSB: start and stop Nagios monitoring server    Loaded: loaded (/etc/rc.d/init.d/nagios)    Active: activating (start) since śro 2015-11-04 17:44:43 CET; 3min 57s ago   Process: 26524 ExecStart=/etc/rc.d/init.d/nagios start (code=exited, status=0/SUCCESS)    CGroup: /system.slice/nagios.service
           ├─26645 /usr/local/nagios/bin/nagios -ud /usr/local/nagios/etc/nagios.cfg
           ├─26647 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
           ├─26648 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
           ├─26649 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
           ├─26650 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
           └─26657 /usr/local/nagios/bin/nagios -ud /usr/local/nagios/etc/nagios.cfg

lis 04 17:44:45 Cogythos nagios[26645]: nerd: Channel servicechecks registered successfully lis 04 17:44:45 Cogythos nagios[26645]: nerd: Channel opathchecks registered successfully lis 04 17:44:45 Cogythos nagios[26645]: nerd: Fully initialized and ready to rock! lis 04 17:44:45 Cogythos nagios[26645]: wproc: Successfully registered manager as @wproc with query handler lis 04 17:44:45 Cogythos nagios[26645]: wproc: Registry request: name=Core Worker 26650;pid=26650 lis 04 17:44:45 Cogythos nagios[26645]: wproc: Registry request: name=Core Worker 26647;pid=26647 lis 04 17:44:45 Cogythos nagios[26645]: wproc: Registry request: name=Core Worker 26648;pid=26648 lis 04 17:44:45 Cogythos nagios[26645]: wproc: Registry request: name=Core Worker 26649;pid=26649 lis 04 17:44:45 Cogythos systemd[1]: PID file /var/nagios/nagios.pid not readable (yet?) after start. lis 04 17:44:45 Cogythos nagios[26645]: Successfully launched command file worker with pid 26657

Also there are no warnings/errors

[root@Cogythos nagios]# /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

Nagios Core 4.0.1 Copyright (c) 2009-present Nagios Core Development Team and Community Contributors Copyright (c) 1999-2009 Ethan Galstad Last Modified: 10-15-2013 License: GPL

Website: http://www.nagios.org Reading configuration data...    Read main config file okay...    Read object config files okay...

Running pre-flight check on configuration data...

Checking objects...
        Checked 8 services.
        Checked 1 hosts.
        Checked 1 host groups.
        Checked 0 service groups.
        Checked 1 contacts.
        Checked 1 contact groups.
        Checked 24 commands.
        Checked 5 time periods.
        Checked 0 host escalations.
        Checked 0 service escalations. Checking for circular paths...
        Checked 1 hosts
        Checked 0 service dependencies
        Checked 0 host dependencies
        Checked 5 timeperiods Checking global event handlers... Checking obsessive compulsive processor commands... Checking misc settings...

Total Warnings: 0 Total Errors:   0

Things look okay - No serious problems were detected during the pre-flight check [root@Cogythos nagios]#

Status after ~2 minutes

    [root@Cogythos nagios-4.0.1]# service nagios status
nagios.service - LSB: start and stop Nagios monitoring server
   Loaded: loaded (/etc/rc.d/init.d/nagios)
   Active: failed (Result: timeout) since śro 2015-11-04 18:37:42 CET; 1min 16s ago
  Process: 3794 ExecStart=/etc/rc.d/init.d/nagios start (code=exited, status=0/SUCCESS)

lis 04 18:32:42 Cogythos systemd[1]: Starting LSB: start and stop Nagios monitoring server...
lis 04 18:32:42 Cogythos nagios[3794]: nagios (PID 3050 2983 2982 2981 2980 2959) jest uruchomione...
lis 04 18:32:42 Cogythos systemd[1]: PID file /var/nagios/nagios.pid not readable (yet?) after start.
lis 04 18:37:42 Cogythos systemd[1]: nagios.service operation timed out. Terminating.
lis 04 18:37:42 Cogythos systemd[1]: Failed to start LSB: start and stop Nagios monitoring server.
lis 04 18:37:42 Cogythos systemd[1]: Unit nagios.service entered failed state.
[root@Cogythos nagios-4.0.1]#

Please help. Thanks in advance, MajQel.

  • Starting it that way, is it reading that config /usr/local/nagios/etc/nagios.cfg? – Recct Nov 4 '15 at 17:02
  • Yes, in other case it would failed "/usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg" – MajQel Nov 4 '15 at 17:20
  • but you run that second command, aren't you? what I'm asking is whether starting the service loads the right cfg for the daemon? (i'm not questioning whether the config is correct as it is as indicated by your command) – Recct Nov 4 '15 at 17:21
  • Sorry but I'm pretty fresh .... how can I check this? – MajQel Nov 4 '15 at 17:33
  • After more 1~2 minutes service become failed(timeout) status – MajQel Nov 4 '15 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.