I'm Running HyperV in Win2012 R2 on a laptop for lab. I tried running the battery low so it will initiate a shutdown of the VMs at 50% battery. As a result the host just shutdown and kills off all the VMs rather than gracefully shutting them down.

enter image description here

All the VMs has "Shut down the guest operating system" enabled. "Operating system shutdown" within integration services ticked. It also has Integration services installed on all the VMs. The VMs are server 2012 r2 and ubuntu 14.04.

If I do a manual reboot on the HyperV host, it also doesn't shutdown the VM gracefully. It just kills them all off and reboots within 5 seconds.

  • Do you have the Hyper-V Integration Services installed on the virtual machines and do you have Operating system shutdown enabled in the integration services for each virtual machine?
    – joeqwerty
    Nov 5 '15 at 17:00
  • @joeqwerty yes i have both. Turns out that there is a KB patch to fix this issue.
    – lbanz
    Nov 5 '15 at 18:24

This is a known problem. One of the solutions may be: https://support.microsoft.com/en-us/kb/2896800. Or employ scripts to shutdown the VMs before shutting down the host.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.