1

How do I enable RDP on a GCE instance of Windows Server 2012 R2 Datacenter? Also, if I can't RDP into this server, how can I verify (from server side) that RDP is enabled?

I have spun up an instance (about 30 mins ago), have a firewall rule in place that allows RDP (tcp:3389), my laptop IP address is included in Source tag / IP Range, but I keep getting an error when trying to access via Chrome RDP:

Chrome RDP error msg

  • You put your laptop's IP, or the public IP seen by the server? – GregL Nov 9 '15 at 13:18
  • Yes, ip address is correctly listed. – Thom Rogers Nov 9 '15 at 19:26
  • The public ip of my laptop – Thom Rogers Nov 9 '15 at 19:27
1

The RDP service is enabled on GCE Windows VM machines by default. There can be different reasons cause the issue you're experiencing.

Make sure the IP address that you specified on source filter of the RDP firewall rule is your external IP address that firewall sees. Click on this link and check if it matches to the IP address you've specified in your firewall rule. Also, make sure your remote network is not blocking the outgoing RDP traffics to Internet.

If all are good, reboot the VM and try to connect after Windows VM is fully started up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.