1

So basically, I want to host a network smb share on my Redhat 6.2 Apache httpd server. My basic configuration is outlined below, however, I keep getting errors.

So my basic configuration

/mnt/ShareDocs -> network \\smb\share

/etc/fstab

//smb/shared /mnt/ShareDocs cifs defaults,wsize=65535,file_mode=0777,dir_mode=0777,sec=ntlm,credentials=/root/.creds 0 0

Apache 2.2 (httpd.conf)

<Directory "/var/www/help">
  Options Indexes FollowSymLinks
  AllowOverride None
  Order allow,deny
  Allow from all
</Directory>

Alias /help /var/www/help

tail -f error_log gives me -> Symbolic link not allowed or link target not accessible: /var/www/help

So I take the symbolic link out of the equation, and go directly at the mount point. I change my directory to ...

<Directory "/mnt/ShareDocs"> ...

I then get a different error message that says..

[error] [client ip] (13)Permission denied: access to /help/Manual.pdf denied

Does anyone have any ideas?

  • What distro is this ? – user9517 Nov 6 '15 at 21:38
  • @Iain I noticed that I didn't supply that piece of information, I just updated my question. – jtoepfer Nov 6 '15 at 21:39
  • Is SELinux enabled ? – user9517 Nov 6 '15 at 21:40
  • @Iain yes >sestatus --> SELinux status: enabled – jtoepfer Nov 6 '15 at 21:42
0

Your problem will quit likely be due be due to SELinux.

First set SELinux into permissive mode

setenforce 0

and then test your setup. If it now works then SELinux is proved to be the culprit.

You can use the tools available to figure out what needs changing.

grep denied /var/log/audit/audit.log | audit2why

or look at

grep denied /var/log/audit/audit.log | audit2allow

and take appropriate action.

Don't forget to set SELinux back to enforcing

setenforce 1

Disabling SELinux isn't a good solution.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.