1

I want to run supervisor in my Django server with gunicorn and Nginx, but when I run "supervisord" the supervisor log says:

2015-11-06 23:23:36,746 INFO daemonizing the supervisord process
2015-11-06 23:23:36,749 INFO supervisord started with pid 13766
2015-11-06 23:23:37,758 INFO spawned: 'gunicorn' with pid 13773
2015-11-06 23:23:37,767 INFO exited: gunicorn (exit status 127; not expected)
2015-11-06 23:23:38,771 INFO spawned: 'gunicorn' with pid 13774
2015-11-06 23:23:38,802 INFO exited: gunicorn (exit status 127; not expected)
2015-11-06 23:23:40,807 INFO spawned: 'gunicorn' with pid 13775
2015-11-06 23:23:40,817 INFO exited: gunicorn (exit status 127; not expected)
2015-11-06 23:23:43,823 INFO spawned: 'gunicorn' with pid 13776
2015-11-06 23:23:43,833 INFO exited: gunicorn (exit status 127; not expected)
2015-11-06 23:23:44,834 INFO gave up: gunicorn entered FATAL state, too many start retries too quickly

it is my spervisor conf file:

[supervisord]
logfile=/tmp/supervisord.log ; (main log file;default $CWD/supervisord.log)
logfile_maxbytes=50MB        ; (max main logfile bytes b4 rotation;default 50MB)
logfile_backups=10           ; (num of main logfile rotation backups;default 10)
loglevel=info                ; (log level;default info; others: debug,warn,trace)
pidfile=/tmp/supervisord.pid ; (supervisord pidfile;default supervisord.pid)
nodaemon=false               ; (start in foreground if true;default false)
minfds=1024                  ; (min. avail startup file descriptors;default 1024)
minprocs=200                 ; (min. avail process descriptors;default 200)
;umask=022                   ; (process file creation umask;default 022)
;user=chrism                 ; (default is current user, required if root)
;identifier=supervisor       ; (supervisord identifier, default is 'supervisor')
;directory=/tmp              ; (default is not to cd during start)
;nocleanup=true              ; (don't clean up tempfiles at start;default false)
;childlogdir=/tmp            ; ('AUTO' child log dir, default $TEMP)
;environment=KEY="value"     ; (key value pairs to add to environment)
;strip_ansi=false            ; (strip ansi escape codes in logs; def. false)

; the below section must remain in the config file for RPC
; (supervisorctl/web interface) to work, additional interfaces may be
; added by defining them in separate rpcinterface: sections
[rpcinterface:supervisor]
supervisor.rpcinterface_factory = supervisor.rpcinterface:make_main_rpcinterface


[program:gunicorn]
    command=/home/ligorio/Documentos/Easycredit/entorno/bin/gunicorn easyc.wsgi:application --env DJANGO_SETTINGS_MODULE='easyc.settings.local'  --bind 127.0.0.1:8000 --pid /tmp/gunicorn.pid   ; the program (relative uses PATH, can take args)
    directory=/tmp/flink/
    ;process_name=%(program_name)s ; process_name expr (default %(program_name)s)
    ;numprocs=1                    ; number of processes copies to start (def 1)
    ;directory=/tmp                ; directory to cwd to before exec (def no cwd)
    ;umask=022                     ; umask for process (default None)
    ;priority=999                  ; the relative start priority (default 999)
    ;autostart=true                ; start at supervisord start (default: true)
    ;autorestart=unexpected        ; whether/when to restart (default: unexpected)
    ;startsecs=1                   ; number of secs prog must stay running (def. 1)
    ;startretries=3                ; max # of serial start failures (default 3
    ;exitcodes=0,2                 ; 'expected' exit codes for process (default 0,2)
    ;stopsignal=QUIT               ; signal used to kill process (default TERM)
    ;stopwaitsecs=10               ; max num secs to wait b4 SIGKILL (default 10)
    ;stopasgroup=false             ; send stop signal to the UNIX process group (default false)
    ;killasgroup=false             ; SIGKILL the UNIX process group (def false)
    ;user=chrism                   ; setuid to this UNIX account to run the program
    ;redirect_stderr=true        

Anyone knows what happend??

  • Are you still experiencing this issue? I am having the same problem. What happens if you try to run gunicorn manually? gunicorn YourProject.wsgi:application --bind=unix:/path/to/gunicorn.sock – Adam Starrh Nov 21 '15 at 9:38
  • Are you sure you have a module called easyc with a wsgi application available in /tmp/flink? – Joost Dec 20 '15 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.