1

I want to upgrade my PHP version. When updating to PHP 5.5

yum -y install php55w php55w-opcache

I get this error:

Error: Package: php55w-opcache-5.5.30-2.w6.x86_64 (webtatic)
           Requires: php55w-common(x86-64) = 5.5.30-2.w6
           Available: php55w-common-5.5.30-2.w6.x86_64 (webtatic)
               php55w-common(x86-64) = 5.5.30-2.w6

How can i fix this?

1 Answer 1

1

As the error indicates, this should do the trick:

yum install php55w-common

Then your initial command should work:

yum install php55w php55w-opcache

Or combine into one:

yum install php55w-common php55w php55w-opcache

In case of repo related problems like obsolete packages, force use of a specific repo like so, in this case using remi which contains newer versions of php than most stock OS repo's include:

yum --disablerepo="*" --enablerepo="remi" install php55w-common php55w php55w-opcache

Do note though that PHP 5.5 is already outdated too:

http://php.net/supported-versions.php

5.6 would be a much better choice for long term support, security and speed.

3
  • when i use the first command i get this: Package php55w-common-5.5.30-2.w6.x86_64 is obsoleted by php-common-5.5.30-1.el6.remi.x86_64 which is already installed Nothing to do
    – RoRo
    Nov 8, 2015 at 20:19
  • See edits, in that case it would be better to force php installation through the remi repo you have enabled. Then again, 5.6 would be a better choice of your application code supports it.
    – JayMcTee
    Nov 8, 2015 at 20:23
  • this worked did the trick without any errors, thanks! Now i can't restart httpd, please see my topic: serverfault.com/questions/734820/…
    – RoRo
    Nov 8, 2015 at 20:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .