8

My domain bytecode77.com (analytics) is using a RapidSSL certificate. Firefox doesn't trust that one, so I installed a CA certificate.

I used the one below. I placed it in /usr/local/share/ca-certificates/ca.crt and I ran update-ca-certificates. Then I restarted apache.

But Firefox still doesn't trust the certificate. What is going wrong here?

My vHost

<VirtualHost *:443>
    ServerName bytecode77.com
    DocumentRoot /var/www/bytecode77/html

    SSLEngine on
    SSLCertificateFile /var/www/bytecode77/root/bytecode77.com.crt
    SSLCertificateKeyFile /var/www/bytecode77/root/bytecode77.com.key
</VirtualHost>

CA certificate

-----BEGIN CERTIFICATE-----
MIIEJTCCAw2gAwIBAgIDAjp3MA0GCSqGSIb3DQEBCwUAMEIxCzAJBgNVBAYTAlVT
MRYwFAYDVQQKEw1HZW9UcnVzdCBJbmMuMRswGQYDVQQDExJHZW9UcnVzdCBHbG9i
YWwgQ0EwHhcNMTQwODI5MjEzOTMyWhcNMjIwNTIwMjEzOTMyWjBHMQswCQYDVQQG
EwJVUzEWMBQGA1UEChMNR2VvVHJ1c3QgSW5jLjEgMB4GA1UEAxMXUmFwaWRTU0wg
U0hBMjU2IENBIC0gRzMwggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQCv
VJvZWF0eLFbG1eh/9H0WA//Qi1rkjqfdVC7UBMBdmJyNkA+8EGVf2prWRHzAn7Xp
SowLBkMEu/SW4ib2YQGRZjEiwzQ0Xz8/kS9EX9zHFLYDn4ZLDqP/oIACg8PTH2lS
1p1kD8mD5xvEcKyU58Okaiy9uJ5p2L4KjxZjWmhxgHsw3hUEv8zTvz5IBVV6s9cQ
DAP8m/0Ip4yM26eO8R5j3LMBL3+vV8M8SKeDaCGnL+enP/C1DPz1hNFTvA5yT2AM
QriYrRmIV9cE7Ie/fodOoyH5U/02mEiN1vi7SPIpyGTRzFRIU4uvt2UevykzKdkp
YEj4/5G8V1jlNS67abZZAgMBAAGjggEdMIIBGTAfBgNVHSMEGDAWgBTAephojYn7
qwVkDBF9qn1luMrMTjAdBgNVHQ4EFgQUw5zz/NNGCDS7zkZ/oHxb8+IIy1kwEgYD
VR0TAQH/BAgwBgEB/wIBADAOBgNVHQ8BAf8EBAMCAQYwNQYDVR0fBC4wLDAqoCig
JoYkaHR0cDovL2cuc3ltY2IuY29tL2NybHMvZ3RnbG9iYWwuY3JsMC4GCCsGAQUF
BwEBBCIwIDAeBggrBgEFBQcwAYYSaHR0cDovL2cuc3ltY2QuY29tMEwGA1UdIARF
MEMwQQYKYIZIAYb4RQEHNjAzMDEGCCsGAQUFBwIBFiVodHRwOi8vd3d3Lmdlb3Ry
dXN0LmNvbS9yZXNvdXJjZXMvY3BzMA0GCSqGSIb3DQEBCwUAA4IBAQCjWB7GQzKs
rC+TeLfqrlRARy1+eI1Q9vhmrNZPc9ZE768LzFvB9E+aj0l+YK/CJ8cW8fuTgZCp
fO9vfm5FlBaEvexJ8cQO9K8EWYOHDyw7l8NaEpt7BDV7o5UzCHuTcSJCs6nZb0+B
kvwHtnm8hEqddwnxxYny8LScVKoSew26T++TGezvfU5ho452nFnPjJSxhJf3GrkH
uLLGTxN5279PURt/aQ1RKsHWFf83UTRlUfQevjhq7A6rvz17OQV79PP7GqHQyH5O
ZI3NjGFVkP46yl0lD/gdo0p0Vk8aVUBwdSWmMy66S6VdU5oNMOGNX2Esr8zvsJmh
gP8L8mJMcCaY
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
MIIDfTCCAuagAwIBAgIDErvmMA0GCSqGSIb3DQEBBQUAME4xCzAJBgNVBAYTAlVT
MRAwDgYDVQQKEwdFcXVpZmF4MS0wKwYDVQQLEyRFcXVpZmF4IFNlY3VyZSBDZXJ0
aWZpY2F0ZSBBdXRob3JpdHkwHhcNMDIwNTIxMDQwMDAwWhcNMTgwODIxMDQwMDAw
WjBCMQswCQYDVQQGEwJVUzEWMBQGA1UEChMNR2VvVHJ1c3QgSW5jLjEbMBkGA1UE
AxMSR2VvVHJ1c3QgR2xvYmFsIENBMIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIB
CgKCAQEA2swYYzD99BcjGlZ+W988bDjkcbd4kdS8odhM+KhDtgPpTSEHCIjaWC9m
OSm9BXiLnTjoBbdqfnGk5sRgprDvgOSJKA+eJdbtg/OtppHHmMlCGDUUna2YRpIu
T8rxh0PBFpVXLVDviS2Aelet8u5fa9IAjbkU+BQVNdnARqN7csiRv8lVK83Qlz6c
JmTM386DGXHKTubU1XupGc1V3sjs0l44U+VcT4wt/lAjNvxm5suOpDkZALeVAjmR
Cw7+OC7RHQWa9k0+bw8HHa8sHo9gOeL6NlMTOdReJivbPagUvTLrGAMoUgRx5asz
PeE4uwc2hGKceeoWMPRfwCvocWvk+QIDAQABo4HwMIHtMB8GA1UdIwQYMBaAFEjm
aPkr0rKV10fYIyAQTzOYkJ/UMB0GA1UdDgQWBBTAephojYn7qwVkDBF9qn1luMrM
TjAPBgNVHRMBAf8EBTADAQH/MA4GA1UdDwEB/wQEAwIBBjA6BgNVHR8EMzAxMC+g
LaArhilodHRwOi8vY3JsLmdlb3RydXN0LmNvbS9jcmxzL3NlY3VyZWNhLmNybDBO
BgNVHSAERzBFMEMGBFUdIAAwOzA5BggrBgEFBQcCARYtaHR0cHM6Ly93d3cuZ2Vv
dHJ1c3QuY29tL3Jlc291cmNlcy9yZXBvc2l0b3J5MA0GCSqGSIb3DQEBBQUAA4GB
AHbhEm5OSxYShjAGsoEIz/AIx8dxfmbuwu3UOx//8PDITtZDOLC5MH0Y0FWDomrL
NhGc6Ehmo21/uBPUR/6LWlxz/K7ZGzIZOKuXNBSqltLroxwUCEm2u+WR74M26x1W
b8ravHNjkOR/ez4iyz0H7V84dJzjA1BOoa+Y7mHyhD8S
-----END CERTIFICATE-----
23

Your certificate chain is incomplete. You need to add a SSLCertificateChainFile line, and the file needs to include the "RapidSSL SHA256 CA - G3" intermediate certificate.

Firefox trusts the Geotrust global CA, but without sending it the intermediate cert as well, it doesn't know who signed your certificate so doesn't trust it.

RapidSSL has a good tutorial, including where to get the needed files, here: https://knowledge.rapidssl.com/support/ssl-certificate-support/index?page=content&id=SO6252

  • Interesting. This previously didn't work, but now it also works without it, meaning that my previous attempt just "took time"... I don't know. Now it's working... – bytecode77 Nov 9 '15 at 13:25
  • @bytecode77 Your previous attempt shouldn't have worked. Without the entry in your virtual host configs there's nothing to tell Apache to send the cert chain. You may want to do some more testing from other computers/browsers just to make sure that things are actually working as expected. – David King Nov 9 '15 at 14:30
  • 4
    @bytecode77. Sometimes, once a browser gets an intermediate certificate from somewhere, it stores it. And then if it's later visiting a site which relies on that cert, and doesn't supply it, it will work, because the browser has it in its cache. So it may now work for you, because you happened to visit another site which relied on the same intermediate cert, and supplied it to your browser. – TRiG Nov 9 '15 at 21:37
  • 1
    nvm. I installed firefox on my VM. Then I accessed my website without the SSLCertificateChainFile. It didn't work. When I added this parameter, it worked. Therefore this is prove that this solution works. What a great reliev. – bytecode77 Nov 9 '15 at 22:02
  • 1
    Since Apache 2.4.8 SSLCertificateChainFile is deprecated. You just need to append CA certificates to the SSLCertificateFile file. – Gustavo Rodrigues Nov 10 '15 at 10:54
5

Update your virtual host configuration as follows

<VirtualHost *:443>
    ServerName bytecode77.com
    DocumentRoot /var/www/bytecode77/html

    SSLEngine on
    SSLCertificateFile /var/www/bytecode77/root/bytecode77.com.crt
    SSLCertificateChainFile /usr/local/share/ca-certificates/ca.crt
    SSLCertificateKeyFile /var/www/bytecode77/root/bytecode77.com.key
</VirtualHost>

to instruct Apache to send the certificate chain along with the certificate.

0

In my case, installing the Intermediate and Root certificates linked in the email along with the SSL certificate did not work, but Geotrust has a tool that helped me.

https://cryptoreport.geotrust.com/checker/views/certCheck.jsp

It linked me directly to the certificate I needed.

Geotrust errors

After installing

No Errors

No errors on Firefox, Safari, or Chrome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.