1

I have a server (Lenovo TD340) running 2012 R2 standard. I've been using the server without a mouse for a while as I didn't have one handy. Recently got a mouse (Logitech USB) and hooked it up. Moments later it started working as expected. But the next time I tried to reboot the server I get a:

pnp_detected_fatal_error

BSOD on startup and the server won't boot.

Removed mouse -- server boots normally. First time I've seen a mouse bring down a server.

Noticed in the Device Manager there are 3 "USB HID Compliant Mouse" listed. I try removing them all and restarting with mouse plugged in. Server boots ok, but reinstalls the 3 drivers again. And sure enough on next boot I get the BSOD error.

So I disable 2 of the entries leaving only one. Server now boots normally on subsequent reboots with mouse plugged in so my problem is "solved". But the solution seems inelegant and I fear I may have a deeper problem.

Any ideas on how I can more permanently resolve this problem so that Windows does not try to install multiple drivers.

(Also, I've tried multiple different mice)

3
  • Do you use a USB hub ? Remove it if so. Did you try a standard mouse, like the one that ship with the server
    – yagmoth555
    Nov 10, 2015 at 16:37
  • No USB hub. No mouse/keyboard shipped with the server. But this is a pretty standard Logitech wired mouse: newegg.com/Product/Product.aspx?Item=9SIA1N82KJ1783
    – scotru
    Nov 10, 2015 at 23:47
  • If no hub, I think of a usb controller failure. Can you update the firmware of the motherboard and after try other usb device.
    – yagmoth555
    Nov 11, 2015 at 1:43

0

You must log in to answer this question.

Browse other questions tagged .