20

I'm running Ubuntu 15.04. I have the newest version of IBus installed, so does the command show:

apt-get changelog ibus

But the software I use (PHPStorm 10) gives a warning that IBus with version at least 1.5.11 is recommended. How can I install it?

20

Installed now these builds https://launchpad.net/~tista/+archive/ubuntu/wayland/+build/8264511

Download the following files in a folder

gir1.2-ibus-1.0_1.5.11+git20151104-2-0ubuntu1~xenial1_amd64.deb
ibus_1.5.11+git20151104-2-0ubuntu1~xenial1_amd64.deb
ibus-gtk_1.5.11+git20151104-2-0ubuntu1~xenial1_amd64.deb
ibus-gtk3_1.5.11+git20151104-2-0ubuntu1~xenial1_amd64.deb
libibus-1.0-5_1.5.11+git20151104-2-0ubuntu1~xenial1_amd64.deb

Install

sudo dpkg -i *.deb

Don't pay attention to the warnings and restart

  • this was very useful for me! thank you +1. – 1111161171159459134 Nov 17 '15 at 18:07
  • Install went smoothly for me. Can't tell yet if the infuriating bug with the keyboard suddenly stopping in PHPStorm is finally over... But if that don't work or for those who can't upgrade ibus, uninstalling ibus completely fixed the problem for me in the past, without much negative side effects (despite non-US keyboard). – rixo Nov 20 '15 at 9:20
  • Thanks. Works on Ubuntu 15.10, too. I didn't notice a negative side effect so far. – DanielaWaranie Dec 5 '15 at 18:17
  • I did the dpkg but the installation seems to have failed in Ubuntu 14.04 LTS: Errors were encountered while processing: gir1.2-ibus-1.0:amd64 ibus even though ibus version displays IBus 1.5.11 now. – Vadorequest Jan 26 '16 at 8:59
  • 1
    One-liner for the lazy ones: mkdir -p /tmp/ibus && cd /tmp/ibus && curl -O http://launchpadlibrarian.net/234615974/gir1.2-ibus-1.0_1.5.11-1ubuntu2_amd64.deb -O http://launchpadlibrarian.net/234615976/ibus-gtk_1.5.11-1ubuntu2_amd64.deb -O http://launchpadlibrarian.net/234615975/ibus-gtk3_1.5.11-1ubuntu2_amd64.deb -O http://launchpadlibrarian.net/234615978/ibus_1.5.11-1ubuntu2_amd64.deb -O http://launchpadlibrarian.net/234615979/libibus-1.0-5_1.5.11-1ubuntu2_amd64.deb && sudo dpkg -i *.deb – Flatron Apr 11 '16 at 11:43
4

Based on some of the comments, I chose to install ibus 1.5.12. I'm using Ubuntu 14.04, and based on the reply from @Fabio, this worked for me here is the source location: https://launchpad.net/~tista/+archive/ubuntu/wayland/+build/8927526

gir1.2-ibus-1.0_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb
ibus_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb
ibus-gtk3_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb
ibus-gtk_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb
libibus-1.0-5_1.5.12+git20160201-0ubuntu1-xenial1_amd64.deb

EDIT - errors with dpkg
Errors when de-packaging are probably related to unmet dependencies.
Download from Ubuntu-Packages the missing packages.
Manually de-package until dependencies are met.
Then try de-packaging the above packages again.

1

After downloading the packages from https://launchpad.net/~tista/+archive/ubuntu/wayland/+build/8927526 and then running dpkg -i *.deb on the downloaded packages, run

apt-get install -f

to fix the errors that happened during the dpkg install (some dependencies are missing).

Can confirm it working on Ubuntu 15.10

1

I'm on Ubuntu 14.04.5 and ran into the same problem with Android Studio. I prefer to upgrade ibus if possible. Turns out, it was very easy^^.

  1. Update sources.list with these two lines:

    deb http://ca.archive.ubuntu.com/ubuntu/ xenial main restricted
    deb-src http://ca.archive.ubuntu.com/ubuntu/ xenial main restricted
    
  2. Update ibus:

    sudo apt-get update
    sudo apt-get install ibus
    
  3. Remove the added lines from sources.list.

Before updating sources.list:

sudo apt-cache policy ibus
ibus:  
  Installed: 1.5.5-1ubuntu3.2  
  Candidate: 1.5.5-1ubuntu3.2  
  Version table:  
  *** 1.5.5-1ubuntu3.2 0  
        500 http://ca.archive.ubuntu.com/ubuntu/ trusty-updates/main 
amd64 Packages
        100 /var/lib/dpkg/status
     1.5.5-1ubuntu3 0
        500 http://ca.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

After updating ibus:

sudo apt-cache policy ibus
ibus:
  Installed: 1.5.11-1ubuntu2
  Candidate: 1.5.11-1ubuntu2
  Version table:
 *** 1.5.11-1ubuntu2 0
        500 http://ca.archive.ubuntu.com/ubuntu/ xenial/main amd64 Packages
        100 /var/lib/dpkg/status
     1.5.5-1ubuntu3.2 0
        500 http://ca.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
     1.5.5-1ubuntu3 0
        500 http://ca.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

^^Too easy. I'm suspicious that something's going to explode shortly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.