1

I have a RHEL 6.7 server running: Apache: 2.2.15 PHP 5.3.3 getenforce => Disabled

As is, its working fine. The web master for the server tells me that PHP-5.3 will no longer work with Facebook's API and that I need to upgrade to 5.4 or later. Attempting to do this, I have followed the steps at http://developerblog.redhat.com/2013...6-using-rhscl/ The only real change I made was to do: ' rhn-channel --add --channel=rhel-x86_64-server-6-rhscl-1' since the article is a bit dated. Other than that I followed the steps closely. I even got the

"[warn] module php5_module is already loaded, skipping"

To solve it, I did 'mv /etc/httpd/conf.d/php.conf /etc/httpd/conf.d/php.conf.php5.3' to keep it from running when Apache starts. I then restarted apache. This is what I get in the error logs.

[Wed Nov 11 11:41:59 2015] [notice] caught SIGTERM, shutting down
[Wed Nov 11 11:41:59 2015] [notice] suEXEC mechanism enabled (wrapper:
 /usr/sbin/suexec)
[Wed Nov 11 11:41:59 2015] [notice] Digest: generating secret for digest authentication ...
[Wed Nov 11 11:41:59 2015] [notice] Digest: done
[Wed Nov 11 11:41:59 2015] [notice] Apache/2.2.15 (Unix) PHP/5.4.40 mod_ssl/2.2.15 OpenSSL/1.0.1e-fips configured -- resuming normal operations 

'httpd -M | grep php' shows:

Syntax OK
  php5_module (shared)

All I get is a blank page when I try to load the web page instead of executing index.php like it did before. I think I'm missing something simple. Below is my current /etc/httpd/conf.d/php54-php.conf

Does anyone have any ideas how I can make it run index.php properly? Thank you so much for your time.

Mike

My comment are prefaced by 3 #. Like ###

#
# PHP is an HTML-embedded scripting language which attempts to make it
# easy for developers to write dynamically generated webpages.
# 
<IfModule prefork.c> 
LoadModule php5_module modules/libphp54-php5.so 
</IfModule>

#
# Cause the PHP interpreter to handle files with a .php extension.
# 
<FilesMatch \.php$>

### Shows a blank page instead of running the PHP code. 
 SetHandler application/x-httpd-php

### Shows the PHP source code instead of running it
#SetHandler application/x-httpd-php5

</FilesMatch>

#
# Allow php to handle Multiviews
#
#
AddHandler php5-script .php AddType text/html .php

### Seems to have no effect
#AddType application/x-httpd-php .php

### Seems to have no effect
#AddType application/x-httpd-php-source .phps

#
# Add index.php to the list of files that will be served as directory
# indexes.
# 
DirectoryIndex index.php

#
# Uncomment the following lines to allow PHP to pretty-print .phps
# files as PHP source code:
#
#<FilesMatch \.phps$>
# SetHandler application/x-httpd-php-source
#</FilesMatch>

#
# Apache specific PHP configuration options
# those can be override in each configured vhost
# 
php_value session.save_handler "files" 
php_value session.save_path "/opt/rh/php54/root/var/lib/php/session"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.