2

This question already has an answer here:

i tried to install drupal on centos, i have configure my server (install httpd, mysql, php, etc) everything looks good until the last part: hit the url to install drupal

the problem here is once i hit the url/ip addr it return me 403 forbidden.

but it is weird because i put phpinfo.php at the same folder with the same group,owner and permission and i can see the page...

any idea what possibly went wrong?

Edit: httpd error log:

[Thu Nov 12 01:43:38.757390 2015] [core:error] [pid 2600] (13)Permission denied: [client 192.168.yy.xx:53408] AH00035: access to /index.php denied (filesystem path '/var/www/html/index.php') because search permissions are missing on a component of the path

okay, i found the issue here, it is because the selinux enabled. i did setenforce 0 and it works... but however any idea how to make this work with selinux enabled (setenforce 1) ?

thanks!

marked as duplicate by mdpc, Michael Hampton Nov 12 '15 at 5:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

you can fix this by running chcon -R -t httpd_sys_content_t /var/www/html/myDrupal. Change /var/www/html/myDrupal to match where your installation is located.

and plus this for a complete solution for Drupal

chcon -t httpd_sys_content_rw_t sites/default/
chcon -t httpd_sys_content_rw_t sites/default/settings.php
chcon -t httpd_sys_content_rw_t sites/default/files

Not the answer you're looking for? Browse other questions tagged or ask your own question.