4

When I run the "find" command in any folder, works perfect, but only in a particular folder I get this:

root#find

. find:.: Value too large for defined data type

It is a shared folder from another server nfs. With umount and mount not change anything. This worked before, but not now. A That is because the "Value too large for defined data type"

  • What distro and architecture is this ? – Iain Nov 11 '15 at 18:33
  • [root@server prueba]#uname -a Linux server 2.6.9-5.ELsmp #1 SMP Wed Jan 5 19:30:39 EST 2005 i686 i686 i386 GNU/Linux [root@server prueba]#lsb_release -a LSB Version: 1.3 Distributor ID: RedHatEnterpriseAS Description: Red Hat Enterprise Linux AS release 4 (Nahant) Release: 4 Codename: Nahant [root@server prueba]# – juan Nov 11 '15 at 18:48
  • 1
    Seems a known bug: bugzilla.redhat.com/show_bug.cgi?id=141167 – Fredi Nov 11 '15 at 19:01
1

Your ancient OS is 32bit something being returned to it is too large for a 32bit value. There is more about the general problem -here.

There is an equally ancient bug report which suggests that the problem is intermittent and suggests downgrading to an earlier version of findutils (findutils-4.1.7-25)- although I wouldn't want to go making changes to that system as it may make it worse.

Your OS is over a decade old - it's probably a good idea to see about bringing it up-to-date.

  • I understand what you say, but in empty subfolders also shows me the error in a directory structure /folder1/folder2/empty_folder. Why it shows me the same error in the empty folder? And higher folders shows me the contents of subfolders without error. – juan Nov 11 '15 at 19:45
0

NFS version 3 may give such kind of errors on old systems. try to mount the same NFS with version 2:

mount -F NFS -o vers=2 200.19.19.19:sharedfact /mnt/thefact

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.