0

I'm trying to get SIP trunking to work on my Bintec Elmeg hybird 130j with sipgate.de as trunking Provider.

So far, call signalisation works fine, so I can call outside phones and also get called from outside my network. But there is no audio at all.

My setup:

  • Hybird 130j PBX: 192.168.250.144
  • Phone 1: 192.168.250.121
  • Gateway: 192.168.250.1

The gateway is connected to the Internet with a public IP. After fiddling with the Firewall, I captured the following:

REGISTER sip:sipconnect.sipgate.de SIP/2.0
Via: SIP/2.0/UDP 192.168.250.144:5060;branch=randomchars1;rport
From: <sip:[email protected]>;tag=randomchars2
To: <sip:[email protected]>
Call-ID: randomchars5Crandomchars4
CSeq: 31 REGISTER
Contact: <sip:[email protected]:5060;transport=udp;line=randomchars2>;+sip.instance="<urn:uuid:00000000-0000-1000-8000-randomchars4>"
Max-Forwards: 70
Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, MESSAGE, SUBSCRIBE, UPDATE, PRACK, REFER
Supported: 100rel, replaces, timer
User-Agent: hybird_130j V.9.1 Rev. 10 (Patch 5) IPSec 
Expires: 60
Authorization: Digest algorithm=MD5, username="myusername", uri="sip:sipconnect.sipgate.de", realm="sipconnect.sipgate.de", nonce="letskeepthatsecret", response="samehere"
Content-Length: 0

SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.250.144:5060;branch=randomchars1;rport=5060
From: <sip:[email protected]>;tag=randomchars2
To: <sip:[email protected]>;tag=randomchars3
Call-ID: randomchars5Crandomchars4
CSeq: 31 REGISTER
Contact: <sip:[email protected]:5060;transport=udp;line=randomchars2>;expires=60;+sip.instance="<urn:uuid:00000000-0000-1000-8000-randomchars4>"
Content-Length: 0

I stripped some information since I assume it's sensitive data(?)

As seen above, both REGISTER and Response packets contain the PBX's local IP 192.168.250.144 in the Via: line. I captured these packets between the PBX and the Gateway on my network.

After SIP Status 180 Ringing there are 10 RTP packets, 1 RTCP Goodbye, then ~200 RTP packets, again followed by RTCP Goodbye. All sent from the PBX, no incoming RTP packets.

Then comes a SIP request: Cancel (sent by PBX), Status 200 and 487 both sent from outside my LAN and an ACK from my PBX.

Now, what can I do to make the hybird 130j send the correct, public IP in the Via: line? Sorry but I'm a beginner to VoIP/SIP.

Do I need a STUN-Server? SIP Proxy? Or is the PBX/Firewall configuration wrong?

BUMP - No feedback so far :(

1 Answer 1

0

Yes, the public IP must be in the SIP header for Calls to work correctly.

Also, ports have to be open for your provider's Registrar, STUN and RTP/Voice Servers. In my case, there are quite a few IP Address/Port combinations that need to be opened for VoIP to work, but at least I can now use it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .