8

[How to change password in Google Developers Console?]

I know this should be a very stupid question related Google Developers Console, but I just wasted three hours in it and no luck in google search results.

This is the first time I enable Developers Console in GAE, it shows the bash shell by default after login. I want to config my preference shell environment zsh, after finishing cloning oh-my-zsh project to local, I run chsh command to switch to zsh, the sudo password is need for that.

The question is I don't know what the password is, I tried google account password and other frequency passwords, it failed.

Using passwd to change the password with my wrong pass shows the following error.

myname@mycloud:~$ passwd
Changing password for myname.
(current) UNIX password: 
passwd: Authentication token manipulation error
passwd: password unchanged

I verified my google account password with login to google, it's right.

Q1: What's the default password? Q2: Can't the console password be changed?

Thanks!

3
  • 1
    Just to make sure I understand correctly, this is Cloud Shell, right? cloud.google.com/cloud-shell/docs
    – cxw
    Nov 13 '15 at 11:17
  • 1
    Or is it the locally-installed Cloud SDK? cloud.google.com/sdk
    – cxw
    Nov 13 '15 at 11:22
  • 1
    Weird, within a tmux session I get prompted for a password, but within the original prompt sudo su for example works - no password prompt. May 11 '20 at 10:39
11

The user account for GCE instance or Cloud Shell has access to elevate the privileges using sudo. The password for the user accounts is not configured out of the box. You can change user account password without providing the current one by running the command:

$ sudo passwd $USER
1
  • 2
    When I run sudo passwd $USER command I receive the following error passwd: Authentication token manipulation error.
    – PapaSmurf
    Jan 31 '20 at 13:12
0

I don't know if you can use "sudo" on Cloud Shell(Google Developers Console).

When I tried to remove "myFolder" running the command below with "sudo":

sudo rm -r myFolder

I was asked for "password" with some messages below:

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for thisUser: 

Then, I don't know the "password" and tried to change or reset the "password" but I couldn't.

Finally, I removed "sudo" from the command and ran it then I could remove "myFolder" without asked for the "password":

rm -r myFolder

That's why I said that I don't know if you can use "sudo" on Cloud Shell(Google Developers Console).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.