3

We are using Kubernetes hosted on Google Container Engine. We have started to see regular pod failures with the following status:

API error (500): error creating aufs mount to /var/lib/docker/aufs/mnt/5d169df4a6720647d46e4f689e3d77fc656f5916db249473f17b29f859d9808c-init: invalid argument

This is causing major issues for us. We have tried moving to a new cluster but are seeing exactly the same issue.

I found the following issues:

But not sure what action we can take?

  • I think you are stuck, until Google deploys that patch. – Michael Hampton Nov 16 '15 at 16:36
4

Kubernetes 1.1.1 has a workaround for that problem. That is currently the default version for new GKE clusters. Existing clusters will be automatically updated soon. If you have an existing cluster that you'd like us to manually upgrade, feel free to jump on Slack and let us know.

3

It looks like an upgrade issue. Try to do the upgrade yourself with the following command:

gcloud container clusters upgrade CLUSTER_NAME --zone=YOUR_ZONE --cluster-version=1.1.1"

If this command fails, than you need to force upgrade the instances by running this command:

gcloud compute instance-groups managed set-instance-template NAME --template TEMPLATE [--zone ZONE]

and then running the following for each node:

gcloud compute instance-groups managed recreate-instances NAME --instances INSTANCE,[INSTANCE,…] [--zone ZONE]
  • thanks for the info, previously tried to update the cluster but it failed. useful to know how to force it – toby Nov 18 '15 at 12:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.