I am new to Domains... Have physical DC. created there 10 users. Have virtualized TS on other PC, joined to domain, all OK. DC can see and manage the TS. ...But still I am unable to allow my domain users (created on DC) to connect to TS through RDP .. Only Administrator can RDP OK, but normal users NOT, even if Members of Remote Desktop users group, still no luck. I tried many tutorials, messed with everything, I am pretty desperate .. Any idea? I did all I could understand here, even according to similar posts, still no luck.... Any ideas? Both OS WS2012

  • Dig into terminal services licensing... By default, two admin users can use RDP - other users need licenses and "licensing" - a server that manages their licenses. – Sergio Nov 16 '15 at 14:07
  • 1
    You need to include error messages, preferably from the client side AND server side (look in the security eventvwr logs). As it currently stands your question just doesn't provide any real details that an expert here can formulate an answer with. – TheCleaner Nov 16 '15 at 14:07

Did you add these users to the domain Remote Desktop Users group? If so, that's your problem. Members of the domain Remote Desktop Users group are not automatically members of the local Remote Desktop Users group on your RDS server. You need to add the domain Remote Desktop Users group to the local Remote Desktop Users group on the server.

Additionally, the domain Remote Desktop Users is meant to grant RDS access to users for the Domain Controller, not for access to RDS servers.


I had a very similar problem. You could remote in as a local computer user, but you could not remote in as a domain user.

Similarly, this was a VM. But in my case it was a VM that was just taken out of storage and was 1 hour off.

Setting the time correctly fixed the issue. I'm not sure why remote desktop didn't alert me to this problem, or why I was able to log in as a domain user from the VM console. But alas...


When I had a problem similar to this, I found that Microsoft Windows DNS was the real problem, associated with its AD integration.

To recap my problem:

My Domain is up, and all of the joined systems are found in domain list. Using the VMware Console, I can log in as Domain\administrator, or as Domain\user, or as MyBox\user onto the MyBox server. Therefore, Authentication was working.

Using Remote Desktop, I cannot login as Domain\Administrator or Domain\user.

When attempting to "Update" the Remote Desktop User list with my Domain group, The server (MyBox) does NOT show me the "Domain" in the list, ONLY the local host name (MyBox).

My Resolution:

Go into Windows DNS on the AD server, and change the domain (or subdomain) properties to use the "Dynamic DNS" mode - yes, the insecure mode. It instantly resolved my authentication issue, allowing me to "find" the AD Domain, select my new Remote_Users group in the domain, and resume work.


I hope I would be able to help you. I was having this issue administering my Window Server 2016 also. I wanted my domain users to be able to establish a remote desktop connection to my Window Server without having to be assigned the role of an administrator.

So I searched everywhere online, messed with a lot of stuff and then got the fix after a lot of trials.

So this is my fix.

Step One: Right click on my computer, click on Properties, click on the Remote Tab, click on Allow Remote access to this computer, click OK

Step Two: Click on Start Menu buttons, search for Local Group Policy, click on Local Profiles, click on user rights, click on Allow log on through Remote Desktop Services, add the users you want, apply, and click OK

Step Three: Perform gpupdate /force

That's it.

Say thank you later.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.