0

I am attempting to set up a set of VMs on Virtualbox and have configured one as a DC running Windows Server 2008 R2, and it's intended to function as a primary DNS server.

I have created a reverse lookup zone of 10.10.10.x. Its adapter address is 10.10.10.10. In Virtualbox, I have left the default adapter settings for the machine alone; it defaulted to NAT.

A second image, also hosting Windows Server 2008 R2, is up on the host. It too has a default adapter type of NAT. I would like this image to use the DC as its primary DNS server. It's address is 10.10.10.20. However, when I try to set the DNS to .10 using

Netsh interface ipv4 set dnsservers "Local Area Connection" static 10.10.10.10 primary

from an elevated command prompt, I get a message indicating the DNS server is incorrect or does not exist.

The host is an OSX machine and again, all images are running on the host. I suspect I have not selected the correct adapter type for one or both of them.

How can I get this machine to use the DC image as its DNS server?

  • 1
    Is this for dev/test or for production? If it's for production, you're in for a world of hurt. – EEAA Nov 17 '15 at 21:06
  • @EEAA Nope, its for development. I am setting up VMs along the guidelines provided for some training I am doing. These are somewhat disposable in that regard. – Elliot Rodriguez Nov 17 '15 at 21:09
2

You are correct about adapter type. "Nat" is creating a different network & adapter for each VM. You need to switch the VMs' adapter types to NatNetwork or Internal networking or Bridged Networking. But certainly just "Nat" is not proper type of adapter.

  • Nat Networking: Both VM should use the same name "NatNetwork" is default
  • Internal Networking: Both VMs' adapter should attached to same name "intnet" default.
  • Bridged Networking. Both uses the same bridge interface created via OS X System preferences > Network > Manage virtual interfaces > Create new bridge

You can get info here. https://www.virtualbox.org/manual/ch06.html#network_internal

  • Thanks - I chose internal networking and I was able to register the DNS entry. – Elliot Rodriguez Nov 17 '15 at 22:20

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.