2

I have a FreeBSD NFS server with a mount, say '/mnt', and some mount points within it, say '/mnt/Documents'. When I mount from CentOS 7, the submounts are mounted automatically:

# mount -t nfs4 -o soft,intr 10.0.0.1:/mnt nfs-test
# ls nfs-test/Documents
stuff

whereas on Fedora:

# mount -t nfs4 -o soft,intr 10.0.0.1:/mnt nfs-test
# ls nfs-test/Documents
ls: reading directory nfs-test/Documents: Input/output error

likewise, if I mount this submount separately, the mount succeeds but I get the same error when I try to read the directory. If I try to mount the submount within the existing parent NFS mount:

mount.nfs4: /home/_/nfs-test/Documents is busy or already mounted

The fact that it works under CentOS leads me to believe there isn't a configuration issue on the server side, but I can provide details about that if necessary.

Please let me know whatever additional details are desired.

Thanks

  • You should check the logs on both the client and the NFS server. – Michael Hampton Nov 18 '15 at 1:58
  • I haven't been able to find any relevant logs on the server or client side – A__A__0 Nov 18 '15 at 3:34
2

I'm reluctant to make this an answer since it turned out to be a silly error. Moreover, the original question of the difference of behavior between the two distributions could still up in the air to some extent. In any case, I had forgotten about the ZFS property I had set on the parent dataset:

router:/root# zfs get sharenfs parent
NAME  PROPERTY  VALUE 
parent  sharenfs  -alldirs -mapall admin -network 192.168.1.1 -mask 255.255.255.0

The CentOS client happened to be on 192.168.1.1/24, and the property is inherited by all the child datasets that I had trouble mounting. Expanding the mask to /16 fixed it.

  • You also forgot to tell us that it was ZFS. Knowing this might have gotten you an answer sooner. If you need to ask future questions, remember to include every relevant detail about the environment. – Michael Hampton Nov 21 '15 at 5:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.