-1

I'm having some issues which i can't figure out, i guess it's a noob question but its giving me a hard time.

I have multiple servers, you can only connect via SSH with a key. They all have the same key of my client.

If i connect to server A it connects directly, also server X. If i connect to server B i'm prompted to enter a password (once) to open my password store, after that i can connect to all servers.

I'm using Fedora as a client.

I have not protected my key (which is the same for all hosts) with a password.I checked the password manager, but it seems not related to this issue.

I see no options/differences between the hosts in the SSH config. Looking at the keychain documentation i think it's unrelated as well.

How can i add a ssh connection to the local password protected list?

2

I have found the solution, it appears on the later installed servers. These servers also have my local DSA key i generated in a later stage.

On fedora there is a gnome-keyring-daemon which only knew the RSA key, thus these new servers connection established with the DSA key.

Deleting the DSA key from the servers authorized keys and restarting the daemon on my client (gnome-keyring-daemon -r -d) showed that these new servers are now also in the ssh-agent.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.