1

Aster standard installation of phpmyadmin on ubuntu 14.04 I found <site>/phpmyadmin doesn't work. After googling I found this can be solved with adding this line Include "/etc/apache2/conf-enabled/*.conf" ..to /etc/apache2/apache2.conf config file.

But after apache reload I get this error message

 * Reloading web server apache2
 * 
 * The apache2 configtest failed. Not doing anything.
Output of config test was:
AH00526: Syntax error on line 30 of /etc/apache2/conf-enabled/phpmyadmin.conf:
Unknown Authz provider: valid-user
Action 'configtest' failed.
The Apache error log may have more information.

How can I fix error and make phpmyadmin working?

  • What's "standard installation" mean here -- did you use the packaged (dpkg/apt/aptitude/etc) version or download the source from phpMyAdmin and uncompress it to your web root? – ibennetch Nov 22 '15 at 15:55
4

It seems that the module 'mod_authz_user' is not enabled. You can use a2enmod to enable it for your apache installation.

sudo a2enmod authz_user

It will now tell you that is has been activated and that you need to restart your apache instance. In Ubuntu 14.04 this can be done as follows:

sudo service apache2 restart
0

I just ran into the same problem ... after replacing a failed harddisk in mdraid and restarting the server in that process Apache failed to start with the same error message:

AH00526: Syntax error on line 30 of /etc/apache2/conf-enabled/phpmyadmin.conf:
Unknown Authz provider: valid-user

But the module authz_user was already loaded. As it turned out the problem was something completely different.

Running sudo apache2ctl -M showed a different error:

AH00526: Syntax error on line 7 of /etc/apache2/sites-enabled/net.example.ghost.conf:
Invalid command '<Proxy', perhaps misspelled or defined by a module not included in the server configuration
Action '-M' failed.

I had to enable a couple of modules and run sudo apache2ctl -M again until all necessary modules were loaded. After that, Apache started without problems, and without any changes in /etc/apache2/conf-enabled/phpmyadmin.conf.

-2

You need to edit phpmyadmin config file /etc/apache2/conf-enabled/phpmyadmin.conf and remove line (30 in my case) Authz provider: valid-user. Save it. Apache should now reload normally, and phpmyadmin should work now.

  • 1
    You just removed the requirement that a user be verified before accessing whatever... just FWIW. – dyasta Dec 30 '16 at 1:40
-3

I put V capitalized in valid-user in my case. I recommend you check If you have the same case .

the route is /usr/share/phpmyadmin/.htaccess

  • 2
    It is unlikely that editing an htaccess file will resolve an error in /etc/apache2/conf-enabled/phpmyadmin.conf .... – HBruijn Jan 25 '16 at 6:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.