1

When I am trying to deploy my laravel project and do a php composer.phar install I get this annoying error. I pulled in my project via git with a git clone. And when I surf to my domainname I would like to see my app obviously :). I've installed a correct version of apache, mysql and php. Everything is up and running.

error:

Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file 
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for brianmcdo/image-palette dev-master -> satisfiable by brianmcdo/image-palette[dev-master].
- brianmcdo/image-palette dev-master requires ext-gd * -> the requested PHP extension gd is missing from your system.
Problem 2
- Installation request for phpunit/phpunit 4.8.18 -> satisfiable by phpunit/phpunit[4.8.18].
- phpunit/phpunit 4.8.18 requires ext-dom * -> the requested PHP extension dom is missing from your system.

When I try to install php-gd or dom I get this error:

Error: php56w-common conflicts with php-common-5.4.16-36.el7_1.x86_64

my php version:(php -v)

PHP 5.6.14 (cli) (built: Oct 16 2015 07:11:57)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies

results of rpm -qa | grep php:

php56w-mbstring-5.6.14-2.w7.x86_64
php56w-cli-5.6.14-2.w7.x86_64
php56w-common-5.6.14-2.w7.x86_64
php56w-5.6.14-2.w7.x86_64
php56w-opcache-5.6.14-2.w7.x86_64
1

Try removing php-common-5.4* and rerun the installation. You must remove old PHP packages before installing replacement.

  • Could you help me out with how I exactly do this? I am kinda new to deployement/linux – Moussa Chaabar Nov 22 '15 at 14:59
  • I've tried something like this yum remove php-common-5.4* but it says no match for argument 5.4* no packages marked for removal – Moussa Chaabar Nov 22 '15 at 14:59
  • So try the whole package name - sudo yum remove php-common-5.4.16-36.el7_1.x86_64 – Linuxer Nov 22 '15 at 15:06
  • I have fixed it and was able to do a php composer.phar for my laravel project but when I go to my domain I still only see the apache testing screen I've also restarted httpd – Moussa Chaabar Nov 22 '15 at 15:20
  • edit your httpd.conf properly. please see the following digitalocean.com/community/tutorials/… regarding the httpd config – Linuxer Nov 22 '15 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.