1

In my bugzilla (hosted in Ubuntu 12.04), emails are geting delayed upto 24hrs and sometimes even more than that. I have also installed Jobqueue.pl as well.

But whenever i am checking the jobqueue status, it gives below output:

$> perl jobqueue.pl -f -d check

PIDFILE=./data/jobqueue.pl.pid

Configuration looks okay

jobqueue.pl running - pid 20278

17448 jobs in the queue.

And this jobs number "17448" keeps on increasing, i don't know whether i am missing something. Could someone help me in fixing it out.

For reference I am running below command to run the Jobqueue.pl:

perl /var/www/bugzilla/jobqueue.pl -f -d restart
4

You haven't given enough information to help you. It's likely that the problem is that Bugzilla is having trouble contacting your SMTP server - perhaps it's overloaded, or refusing connections temporarily, or greylisting, or something. Assuming you've turned on the parameter for delayed mail sending, the likelihood is that all of those jobs are your mail (although 17,000+ emails is a lot!). As to why it's delayed rather than just failing to send entirely, that must be something about your email setup.

All credit goes to Gervase Markham

In this case, run

./jobqueue.pl -f -d once

It will give you the debug logs, from which you can analyse where you are lagging. Fix the issue and run:

./jobqueue.pl -f -d onepass

It will clear all the jobs in one run and exit. Once it is done, you may start your jobqueue as service.

  • Sorry for the delay. I have SMTP server running for bugzilla mails, only issue is it is sending the mails at a delay of around 24 hours. I don't know whether Jobqueue.pl is actually working as intented. It used to work properly for my previous bugzilla version 4.0.1 but not working after upgraded to 4.4.9. Please do let me know if you need any other info. – love Nov 25 '15 at 13:03
  • Well, jobqueue seems to be queueing the jobs, but the reason they are still there is presumably because they are not completing, which suggests that your SMTP server isn't accepting the mails. But without looking at the logs, I couldn't tell. That's what you need to do :-) – Gervase Markham Nov 26 '15 at 14:01
  • 1
    You can stop jobqueue and then run it from the command line as: ./jobqueue.pl -f -d once and it will do one job and hopefully show you the output. That may help. – Gervase Markham Nov 26 '15 at 14:02
  • Thanks Gervase for your reply!! Please find my logs below: ./jobqueue.pl -f -d once PIDFILE=./data/jobqueue.pl.pid Starting up... TheSchwartz::work_once got job of class 'Bugzilla::Job::Mailer', priority 5 Working on Bugzilla::Job::Mailer ... job failed. considering retry. is max_retries of 725 >= failures of 153? job failed: There was an error sending mail from 'bugzilla-daemon@xyz.com' to 'love@xyz.com': Can't send data – love Nov 27 '15 at 12:01
  • Yep - either your Bugzilla can't see the mail server or it's refusing the connections. You need to work out why. This is not a Bugzilla problem :-) – Gervase Markham Nov 28 '15 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.