0

I am trying to troubleshoot the server I mantain. It is a Centos 6.6 with Plesk 12.0.18, it uses Qmail and Courier as email services from what I can see.

Now in general all emails work succesfully and sometimes someone is unable to send emails but they receive an email with the error and we can track it down.

However there are three domains that when they try to send us an email it never reaches our server and they don't receive any error message or any bounce back so there is no way for us to find where the problem is.

I disabled all the SPAM, Domain SPF, and other anti-spam tools to see if they were rejecting them but the emails never come.

How can I find the problem? I checked on the logs for ocurrences of the problematic domains but there are no mentions of them.

  • You can't troubleshoot from your side without assistance from the IT department from the domains not able to send emails to you. Start by having them email someone from your company (preferably the person not getting the emails from the outside domain) and if you can, a public email account you have access to (Gmail, Yahoo, Hotmail, etc...); be sure to have them CC yourself. If your public account gets it, then it's not an issue with the other company. If you don't get the email in your company mailbox, then it's mail server. If the other person doesn't get it, then it's their mailbox. – CIA Nov 23 '15 at 14:31
  • Sadly one of the domains that can't send is other server that we control, hence the possibility of troubleshooting. So I sent an email and cc'd my gmail account and gmail account receives the email straight away and the email account on the server doesn't receive it, nor a message is bounced back. – T. Nacel Nov 23 '15 at 14:42
  • Checked the var/log/maillog for ocurrences of the domain and nothing appears there. – T. Nacel Nov 23 '15 at 15:29
  • Are your mail servers on different servers, subnets or infrastructures? Or do you have one of those super complex setups where you have network load balancers in place or are using one server for multiple domains? Can you provide a simple diagram of your server/network infrastructure? Can you refer to your servers by mock names so it's easier to conceptualize the troubleshooting process (I know it sounds dumb, but I don't work on your systems, so it's very obvious to you which system is which, but it's not obvious to me)? – CIA Nov 23 '15 at 23:18
  • Both servers are in the same company, Donhosts, so to give you an idea the Plesk panels are accessible via ds1234.dedicated.turbodns.co.uk:8443 and ds1235.dedicated.turbodns.co.uk:8443 – T. Nacel Nov 26 '15 at 10:50
0

If the mails never even reach the mail server on the recipient side (no log entries), you will have to debug this on the sending server. Check the logfiles there or use a tool like swaks that shows you the output of the SMTP session.

Syntax for testing with swaks:

swaks -f sender@senderdomain.tld -t recipient@recipientdomain -au mailusername -ap mailuserpassword -s senderserver
  • Tried that. I see that when trying to send to our own server it fails due to username. But it doesn't make sense as our server will never see the username, just the email sending it. i.imgur.com/h8dRXYO.png – T. Nacel Nov 23 '15 at 15:46
  • You're doing it wrong. You have to include the -s senderserver part in your swaks command line, otherwise swaks will connect directly to the recipient server. In your output, both sessions fail because you're trying to authenticate with the senders login at the receiving side. – etagenklo Nov 24 '15 at 11:33
  • I tried again with that and only the gmail account arrives, the other one has the same results on the shell but never arrives. – T. Nacel Nov 24 '15 at 11:46
  • Then you will have to check the logs on the sending server why the mail doesn't get delivered. – etagenklo Nov 24 '15 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.