3

I have a PC running windows 10 enterprise th2 build 1511/10586 The PC is joined to a domain. The issue occurs in a Domain User Account with Standard User permissions. First - The photo app kept on crashing after about 5 seconds of being launched. So i attempted to re-register the UWA's on the PC using ....

Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

(Admin: Powershell)

This did not fix the issue ... so i attempted to do a user re-registration.

Get-AppxPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

(User Level Powershell)

After this i had lost many application ... Photos, store, video, maps, messenger had become all "Semi" registered. No Icons, and long packages names in the start menu - also none of them would launch.

so i tried the Admin registration again... this time receiving my error for the first time .... Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6 .... Merge Failure : error 0x80070003 ... etc for the 5 apps. The rest of the UWA's were unaffected.

At this point i followed -> http://www.howtogeek.com/224798/how-to-uninstall-windows-10s-built-in-apps-and-how-to-reinstall-them/ and attempted to reinstalled the apps.

This did not work either. Photo apps didn't even seem to be found by the Remove-AppxPackage ...

Then i tried...

Get-AppxPackage *photos* | Add-AppxPackage

This appeared to work but did not change anything.

I also tried to login with my username (domain administrator) and theses apps all worked (however the name was not correct). I then performed an all user registration again from admin Powershell, which fixed my profiles app names but did nothing to the other user account.

Doing research this issue has been around for a long time. How do i completely remove these applications, sideload the store app and then proceed to reinstall them like they never existed as i would do with a win32? or alternatively what other ways is there to repair a users installation of these applications?

1

I had this problem too and it made me go rage for weeks. Your question is 6 months old but maybe it is still of interest. I use Windows 10 Professional with Server 2012 R2 in Active Directory.

The error will show something like "NOTE: For additional information, look for [ActivityId]" and suggesting a command to run. Run this command and see what it shows you.

In my case there were "just" some XML files missing for reasons I still don't understand. I found the XML on another computer and messed up the security permissions to the AppRepository folder to access it. But it worked.

Another solution is to reinstall Windows 10 by creating a new Windows installation media and run Setup.exe inside Windows 10, keeping all Settings and Apps. I don't know if this works for Windows 10 Enterprise.

I came into huge problems when deleting local user profile copies to clean up the system, the main and only reason were these corrupted Apps. In my case, I solved it by getting the XML files and making a clean re-installation of all store apps. I had to try multiple times, as lots of files were missing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.