I have wasted nearly a day on this.

I have a fresh Windows Server 2012 R2, fully up to date, that I am trying to install IIS on.

I run the add Roles and Features wizard, select my required features, but the install fails without an error message.

enter image description here

I am unable to find any logs or details to help me trouble shoot what could be wrong.

Task Details shows me nothing:

enter image description here

Could someone please point me to somewhere that could explain my lack of success, or even better, let me know how to get IIS to install?

  • Win2012 R2 requier a liscence, that mean you paid for it. So you have to call Microsoft assistance, they will help you.
    – Froggiz
    Nov 24, 2015 at 9:15
  • @Froggiz if it comes to that I suppose. As a developer, however, I must say that sounds way too much like social pressure. Reinstallation would be far less challenging ;)
    – lagerdalek
    Nov 24, 2015 at 20:23
  • Anything in C:\Windows\IIS.log or C:\Users\you\Appdata\Local\Temp\ServerManager.Log? Add Roles and Features is supposed to write there.
    – Clayton
    Dec 7, 2015 at 22:43
  • Did you ever figure it out? I have the same problem. Jan 5, 2018 at 10:20
  • None of the previous answered helped me with the same situation however I was able to install IIS with powershell.
    – S M Waller
    Nov 13, 2019 at 13:10

4 Answers 4


I had the exact same problem. Could not get any information about what was wrong. However from microsofts own guide there is an option for installing through cmd with:

  Start /w pkgmgr /iu:IIS-WebServerRole;IIS-WebServer;IIS-CommonHttpFeatures;IIS-StaticContent;IIS-DefaultDocument;IIS-DirectoryBrowsing;IIS-HttpErrors;IIS-HealthAndDiagnostics;IIS-HttpLogging;IIS-LoggingLibraries;IIS-RequestMonitor;IIS-Security;IIS-RequestFiltering;IIS-HttpCompressionStatic;IIS-WebServerManagementTools;IIS-ManagementConsole;WAS-WindowsActivationService;WAS-ProcessModel;WAS-NetFxEnvironment;WAS-ConfigurationAPI

For whatever reason this worked while the wizard did not.

  • I get pkgmgr has been deprecated, use dism error Jan 5, 2018 at 10:28

I run into this error while trying to install Request Monitor feature of IIS. In order to troubleshoot it, I would recommend checking:

  • CBS logs (C:\Windows\Logs\CBS)
  • DISM logs (C:\Windows\Logs\DISM)
  • ApplicationHost.config file (C:\Windows\System32\inetsrv\config)
  • The output of Dism /Online /Cleanup-Image /ScanHealth command
  • Procmon logs (Use Process Monitor tool)

In my case Procmon logs showed PARSE_ERROR_INFO while reading applicationHost.config file which was corrupted. Reinstalling IIS solved the issue. 0x800f0922 Update IIS-RequestMonitor of package IIS-WebServer-Core-Package failed

enter image description here


Maybe trying to install IIS with PowerShell will give you a better error message:

Install-WindowsFeature Web-Server



I recently ran into this problem at work. The issue was caused by a Microsoft security update. Specifically KB's 3098779 and 3097997 both cause this behavior. Uninstalling these updates corrected the issue for me.

Here's the KB I used to resolve this issue. https://support.microsoft.com/en-us/kb/3118750

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .