2

I have a working windows 2008 R2 file share that I can connect to from one server (running redhat 6.6) with the following syntax in /etc/fstab

//servername/ELK\es1 /ES1 cifs username=domain\user,password=password 0 0

From here I run sudo mount -a and it mounts successfully, and I can view files in the share if I run ls /ES1

I have another server (the one I actually want the share mounted on), which runs redhat 7.2, and using the exact same syntax in /etc/fstab, and running a sudo mount -av I get the following error: mount error(112): Host is down Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

If I run dmesg I get the following information

CIFS VFS: RFC 1002 unknown response type 0xa CIFS VFS: RFC 1002 unknown response type 0xa CIFS VFS: cifs_mount failed w/return code = -112

I've updated my iptables, and even flushed them so I do not believe it's an issue with ports being blocked. The version of cifs-utils is the same, 1.74.

The only thing I can think that's a difference between the two servers is the version of the OS, one being 6.6 and the other being 7.2.

  • A simple question, can you actually reach/ping the Windows server by it's name from redhat 7.2 server? – Diamond Nov 24 '15 at 20:05
  • yes, it's pingable. I have also tried using the IP instead of FQDN and same behavior. – pcort Nov 24 '15 at 20:06
  • Can you also make sure, that no firewall or antivirus at the windows server are not blocking connection attempt from the redhat 7.2 server? – Diamond Nov 24 '15 at 20:49
  • smb 1 is turned off on the windows server. Redhat 6 smbclient only supports smb1, Redhat 7 supports smb2 – Steven Crawford Mar 9 '17 at 17:34
1

Usually, when I have issues I check the following. I have found I typically forget step b, then try to forge ahead until I get blocked on step e.

  1. Do you have the cifs-utils package installed? It seems so since it at least printed the cifs.mount output. Typically I find cifs and samba as different packages.

  2. Does the connection work if connecting via smbclient? See Mount.cifs vs. SMBClient for an example. This will isolate the mount application. You will need the samba packages for this.

  3. Try to connect with cifs.mount directly with verbose output per man page.

  4. Check the Window-Server event logs to see if the request for a connection is making it to the server.

  5. Beef up the log levels on cifs per the debug section here

  6. Check connectivity in both directions between servers. Make sure the ports for CIFS are open on each end. You can check with nmap.

  7. Check the network configuration of the two Linux servers to make sure there is not some IT device that is stopping one server but not the other.

Finally, I googled some of the error output and got a few links to some options. The Ubuntu pages offer a lot of usage info that is generic.

| improve this answer | |
0

If the normal network reachability using hostname or IP address is working. Then please check and make sure that any Firewall or Antivirus at the Windows Server are not blocking connection attempt from the RedHat 7.2 server.

The error signifies clearly that there is such an issue and that the Redhat Server is unable to connect to the Windows on required ports.

| improve this answer | |
  • I flushed the IP tables and tried it and that didn't work. Also I can connect to the share from other redhat servers so Windows isn't mucking things up. – pcort Nov 24 '15 at 21:19
  • Well, I'm not talking about the Redhat Firewall, rather the Windows Firewall. Have you checked that one? If one host is able to connect to it, doesn't mean all other hosts will be able too. May be you have some host/ip specific rules setup at the Windows server. Do you have access to the Windows server? – Diamond Nov 24 '15 at 21:21
  • windows firewall is off. – pcort Nov 24 '15 at 21:29
  • No Antivirus too? Then run Wireshark at the windows server and try to mount the share, then you will see what is happening, if the requests are reaching it or not. – Diamond Nov 24 '15 at 21:32
  • AV is running, but doesn't appear to be blocking anything. – pcort Nov 24 '15 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.