-1

Well sometimes apparently easy things turn into disaster.

As soon as I add to the VirtualHost:

CustomLog "|usr/sbin/rotatelogs -l ${APACHE_LOG_DIR}/01030/%Y%W_01030.access.log 604800" combined

I get :

[Wed Nov 25 20:08:37.886766 2015] [mpm_prefork:notice] [pid 1381] AH00171: Graceful restart requested, doing restart (2)No such file or directory: AH00104: unable to start piped log program 'usr/sbin/rotatelogs -l /var/log/apache2/40539/%Y%W_40539.access.log 604800'

[Wed Nov 25 20:08:37.992571 2015] [:emerg] [pid 1381] AH00019: Unable to open logs, exiting

Debian 8, Apache 2.4.10.

There must be something in the water. Seen this issue for 2.4.10 around but apparently with no satisfying answer. Help will be appreciated.

5

You're missing the first slash after the pipe. |/usr/sbin/rotatelogs

  • 1
    Thanks a ton for your answer. The missing slash actually was not causing the issue. Now I found out what it was: On my server rotatelogs was at /usr/bin/rotatelogs. This prevented Apache from starting. However, I believe it is good to add the slash as you suggested. – kghbln Nov 25 '15 at 19:34
  • 1
    Interestingly on another machine your suggestion helped avoiding the webserver to crash after a couple of minutes of operation. So your suggestion helps to make the setup stable and avoid aches. Apart from that and upon reflection about the downvotes I received I would like to apologize to have ever asked. – kghbln Sep 14 '16 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.