I am running a CentOS in my Vagrant box and via SSH terminal have run the following command to restart the MySQL service

sudo service mysql restart

The message Shutting down MySQL appears but it never actually completes shutting it down.

If I try running the sudo service mysql start it does the same thing and doesn't complete the process.. any ideas

-- UPDATE --

I have run the command ps aux | grep mysql to find all the MySQL processes and can see i've got a number of processes - I've killed a number of these but a few dont seem to want to be killed? I have used the force kill option e.g sudo kill -9 id and still no joy...

It would appear this is due to zombie processes... can anyone suggest how to destroy this

  • 3
    Any infos in your mysql log ?
    – Froggiz
    Nov 26, 2015 at 10:00
  • Are you sure that the processes that you see are really processes? Not sure about CentOS but Ubuntu's MySQL is threaded. The server should not spawn more than one process due to TCP port or socket path already in use. And what signal is sent by the init script? What happens when you send SIGTERM? I remember MySQL does not quit on some others like SIGQUIT or SIGHUP. Have you tried something like killall -v -s TERM mysqld? Nov 26, 2015 at 11:01
  • please add more info
    – maniat1k
    Nov 26, 2015 at 11:29

1 Answer 1


Fire following commands to restart mysql service

sudo service mysql stop
sudo service mysql start

Hope this helps :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.