0

I've built a test lab running Windows Server 2016 and SCCM 2016 and I'm having an issue with PXE booting a VM to install an OS via SCCM. Here's the run down on the configuration. At this stage SCCM isn't being touched

Windows Server 2016 Technical Preview 4 with Hyper-V Role installed Private Network Virtual Switch, no VLAN set, named "Local only"

VM - DHCP - Gen2 VM - Windows Server 2016 Technical Preview 4 with DHCP Role installed, Network Adapter - On vSwitch "Local Only"

VM - Win10BC - Gen2 VM - No OS (PXE UEFI), Network Adapter - On vSwitch "Local Only"

For both VMs NIC Hardware Acceleration Tab has Enable Virtual Machine Queue ticked, Enable IPsec task offloading ticked with Maximum number: 1

For both VMs NIC Advanced Features Tab has Protected Network ticked

DHCP Server has a single domain authorised IPv4 Scope bound to Eth0 192.168.0.5, NICs from full OS VMs in the same configuration can get a DHCP Lease

Win10BC VM attempts to PXE Boot - "PXE Network Boot using IPv4 ( ESC to cancel), Performing DHCP Negotiation........"

Using Wireshark on DHCP Server I can see DHCP Discover from 0.0.0.0 to 255.255.255.255, DHCP Server Responds 192.168.0.5 to 255.255.255.255 with DHCP Offer.

After a short delay the DHCP Discover and Offer process occurs again and there is no DHCP Request or Acknowledge step returned to the DHCP Server.

It ends up timing out and Virtual Machine Boot Summary, 1. Network Adapter DHCP Failed

This is where I'm stuck, either the DHCP Offer Broadcast isn't reaching the PXE VM or it's receiving and not responding to the DHCP Server. I've tried adding a vLAN to each member, I've tried turning off VMQ and IPsec task offloading, I've turned off Protected network with no change.

On the DHCP Server I've ensured the DHCP firewall rules for IPv4 apply to Domain, Private and Public, Checked the NIC is correctly bound to respond and that other devices can get leases.

All of this is on a single Hyper-V host with the DHCP Server and PXE Guest on the same vSwitch. I realise this is Technical Preview software but I'm hoping there is a solution and this isn't a bug in the preview software.

Has anyone experienced this before? On 2016, 2012? I can provide screenshots of configuration as required.

  • any pxe options configured in dhcp options – Drifter104 Nov 26 '15 at 13:05
  • No PXE options configured, it's in the local subnet so I didn't believe that they were required. I'll add Option 150 and see if it makes a difference but I believe the problem is before the PXE Service Point is reached. – Ben Bowman Nov 27 '15 at 0:13
  • Sorry, Option 66, not 150 – Ben Bowman Nov 27 '15 at 1:01
1

You have a PXE client that is only receiving a DHCP offer w/o PXE information, then it times out and start the DORA (Discover-Offer-Request-ACK) process again. You can see with Wireshark if the DHCP offer contains PXE information or not.

  • I can confirm you are correct. I looked in the DHCP Server's Offer packet and it didn't have any PXE related information. I went back to my Config Manager server and enabled Unknown Computer support in addition to the rest of the standard configuration and I was able to PXE. The next step is now finding out why Unknown computer support was required for a MAC added Device. – Ben Bowman Nov 27 '15 at 3:24
-2

This should be just a quick "normal" comment, but cause of 50 Rep (stupid thing) i just can answer here.

It seems like its cause you use Synthetic Network Adapter, can you try this with with the Legacy Adapter? We got severel issues on PXE Boot with Synt Adapters.

  • Unfortunately not, Gen2 Virtual Machines cannot use Legacy Network adapters, Gen1 Virtual Machines are for Windows 7 and Server 2008 with Gen2 being the standard for 2012R2, Windows 8.1 and upwards. I have a fully functional 2012R2 HyperV configuration that uses Gen2 Virtual Machines and no Legacy NICs and that works fine, so there is something else at play here – Ben Bowman Nov 26 '15 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.