0

According to some info i can find online that PowerEdge R210, the first R210 not the R210 II, is supposed to support port multipliers on its eSata port. And i found examples online of some set up this way, well i for one can't get it working here.

I have a 4-bay Sata enclosure, i think its branded RaidStor on the back but i would have to crawl back behind the rack and double check that, that works with pretty much everything i have ever plugged it into. But when i decided to move it over to the R210 which faithfully sits and churns away with storing backups from the network, i wanted to add this 4-bay enclosure to it for just ease of moving stuff around to external removable drives, i found that all it would see is the first drive, the other three are non-existent. I checked Device Manager, told it to search for new hardware and it picked up the first drive, went to disk management and added that drive, partitioned it added a drive leter yada yada, everything went fine with the first drive but the other three that are in there don't show up. But i can take the eSata cable going to the R210 and plug it into the eSata on my laptop even and i get all four drives so there must be something simple i'm missing here.

The only options in the bios for the eSata port are Automatic or Disabled, so i can't find anything else to set. Its running in non-raid, AHCI, two internal hard drives and an optical drive, i would try putting a PCI-E eSata host card in it or a eSata port on a slot bracket and connect to an internal port to try that but i already have the PCI-E slot taken up by the Perc 6/e thats running the MD1000 attached to this server.

Anyone know if there is something else that needs to be done here? Or is Dell lying about the eSata port on these being PM Aware?

2

I have just tested our Dell PowerEdge R210 and can comfirm that eSATA on debian Wheezy only picks up a single HDD in my 4 bay drive enclosure. Luckily for us, I have an esata pci card that I can put it (will test this out soon). I know my drive bay picks up fine in desktop PC's running Ubuntu 14.04 so I suspect that the esata port is ONLY for 1 drive.

Here is the manual for the R210 which doesn't make mention of multiple drives. http://www.dell.com/downloads/global/products/pedge/en/PowerEdgeR210TechGuide_04052010.pdf

Note, we have ours in ATA mode because the EHCI mode wouldn't pick up our drives --- perhaps a bug in the bios, not sure.

| improve this answer | |
-2

have 2 x 1TB drives as raid 1 on SAS controller, added 1tb drive connected to eSATA It added it as drive D after dire warnings that it was my OS drive. I transferred some data to D, backed up on D then shut down the r210 ii and removed D. When I tried to reboot my RAID was called D not C and system failed to boot into Server 2008 R2. Switched of eSATA in BIOS, same problem. DO NOT use eSATA with BIOS 2.8.0 it seems so think it's a partition of your SAS RAID and when you remove the eSATA system won't boot to Windows ... I took the eSATA drive to a client, I'll get back and see if system works when I plug it back in ...

Plugged eSATA back into server, enabled eSATA, server booted fine :) Now I just have to figure out how to remove eSATA drive from OS so I can disconnect it and boot server without it connected ...

| improve this answer | |
  • 2
    Hi, thanks for the tip, but the OP asked for port multiplicator, thus, sadly, your answer might fail offtopic on that question – yagmoth555 Aug 28 '17 at 2:00
  • What I'm saying is DO NOT use eSATA port on PowerEdge R210 ii for anything or you will have major problems, which is on topic ... – Robert Aug 28 '17 at 3:42
  • I have an R210, not an R210 II, but i do work with R210 II's as well in some locations so thats good info to know thank you! Must be a bios issue. – Scott Lichtsinn Aug 28 '17 at 5:34
  • BIOS is 2.8.0 which works fine on other R210 ii except for eSATA problem. – Robert Aug 28 '17 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.