0

I'm running CentOS 6.7 and I'm trying to successfully establish an FTP connection using vsftpd.

Status:         Connection established, waiting for welcome message...
Response:   220 (vsFTPd 2.2.2)
Command:    AUTH TLS
Response:   234 Proceed with negotiation.
Status:         Initializing TLS...
Status:         Verifying certificate...
Status:         TLS connection established.
Command:    USER testuser
Response:   530 Permission denied.
Error:          Could not connect to server

I tried checking /var/logs/messages and /var/logs/xferlog but the log is empty. I also checked the home directory permissions of the local user and made sure that the user was listed in the userlist and not in the denylist

config:

local_enable=YES
pasv_address=108.41.178.133
pasv_min_port=40000
pasv_max_port=40010
pasv_promiscuous=YES
pasv_enable=YES 
write_enable=YES
local_umask=022
dirmessage_enable=YES
xferlog_enable=YES
xferlog_file=/var/log/xferlog
xferlog_std_format=YES
chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd/chroot_list

listen=YES

pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=YES
rsa_cert_file=/etc/ssl/private/vsftpd.pem
ssl_tlsv1=YES
ssl_sslv2=YES
ssl_sslv3=YES
require_ssl_reuse=NO
ssl_ciphers=HIGH
rsa_private_key_file=/etc/ssl/private/vsftpd.pem

ssl_enable=YES
allow_anon_ssl=NO
force_local_data_ssl=NO
force_local_logins_ssl=YES

dirlist_enable=YES
download_enable=YES

Can someone please point me in the right direction?

  • Is SELinux enabled ? If so try this serverfault.com/questions/302186/…. If that doesn't help and SELinux is enabled show us any relevant messages from /var/log/audit/audit.log – user9517 Dec 1 '15 at 15:32
  • @Iain SELinux is currently disabled. Does it need to be enabled and set to passive? – SlopTonio Dec 1 '15 at 15:32
1

Some options to check:

Is it possible that the username you're specifying is in the /etc/vsftpd/ftpusers list and disallowed from logging in? (usually when a login is rejected before the pasword prompt, that's a sign it's a disallowed user account)

Also, check to see if the user you're logging in with has permissions to access the default home directory on file in vipw

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.