When I try to backup full directories, roughly half of files are copied, other half not.

All error messages are all similar - No such file or directory (2)

rsync: mkstemp "/mnt/NAS/Archive/backup/.../.1.7.8.org.Ittcl6" failed: No such file or directory (2)
rsync: mkstemp "/mnt/NAS/Archive/backup/.../.panda-chair.jpg.fjijU7" failed: No such file or directory (2)
rsync: mkstemp "/mnt/NAS/Archive/backup/.../.DSC_0014.JPG.BJWjxQ" failed: No such file or directory (2)
...
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1165) [sender=3.1.1]

Another time:

rsync: readlink_stat("/mnt/NAS/Archive/backup/.../kviitung_080611.pdf") failed: Permission denied (13)
file has vanished: "/mnt/NAS/Archive/backup/.../keskus"
...
rsync: mkdir "/mnt/NAS/Archive/backup" failed: File exists (17)
rsync error: error in file IO (code 11) at main.c(656) [Receiver=3.1.1]

and so on ...

Mystic part is, that every time I run exactly same script without changing anything, it gives same error messages on different files. That means when I repeatedly run my script, I get all my files copied finally.

There is no problem with file or directory permissions and file or directory names. Only thing i figured out, that it leaves at once full directories empty, but error messages are given per file. And the other thing I figured out, that it creates new copied directories first with root ownership and later changes to actual owner. There is no relevant system messages on both source and destination. There is no other read/write errors just rsync over nfs. Rsync over ssh to the same nas works also without any errors but ssh in local network seems meaningless.

I guess that probably nfs mount is not optimized enough. I'm thankful for any tips !

Some background info:

Source: ext3 drive on Pentium M laptop

Destination: xfs raid 1 nas box ARM4vl 300Mhz 128MB with OpenWRT Barrier Breaker r35972 over nfs mount.

# cat /proc/mounts
192.168.0.100:/mnt/md1 /mnt/NAS nfs rw,relatime,vers=3,rsize=16384,wsize=16384,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.0.100,mountvers=3,mountport=32780,mountproto=udp,local_lock=none,addr=192.168.0.100 0 0

rsync line:

rsync -avR -s -O -i --delete --stats $dir $DESTPATH 2>&1 >> $LOGFILE

PS: Meanwhile I discovered new evidence - rsync works differently after fresh nfs umount/mount cycle. After that it gives "No such file or directory" errors. Following rsyncs are all messed with hundreds of "file has vanished".

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.