I'm having a really strange issue. I'll try to be brief as possible, but I've been through a lot of testing to get here.

Our Environment leading up to this point

  • Office 2010
  • Deployed Lync 2013 (as part of Office 2013 Pro Plus), along side Office 2010
  • Also deployed Excel 2013 to some users
  • KMS used for licensing for Office 2013
  • SP1 is integrated into the Office 2013 source being used, and I used the OCT that comes with the SP1 DVD
  • Deploying 32-bit Office 2013 just like we did with Office 2010
  • This all worked perfectly. Lync installs, and just runs perfectly on first launch and every launch

Now the present issue

  • Now it's time to deploy the rest of Office 2013 and remove Office 2010
  • This works perfectly for people who have no part of Office 2013 already
  • But it has one flaw if part of Office 2013 was previously installed: Lync starts up and says it failed to activate. Then mere seconds after you click Close, it succeeds.

Lync Activation fails

Activation Fails then Succeeds

after that, it's fine for future launches of Lync. Also the Lync icon in the task bar looks like the OneNote icon for that first launch.

Other than that, my deployment would be perfect.

What I've tried

I've updated to the latest OCT and imported my existing MSP. That was just last week to try to resolve some different issues, so pretty sure I have the latest and greatest there.

I tried various attempts with msiexec /p CustomOCT.msp to add the remaining Office 2013 components, but encountered the Lync activation issue PLUS Lync running a repair on first launch, plus some inconsistent behaviour of sometimes seeing the first-run wizard (disabled in the MSP), or having to accept the license (accepted in the MSP).

I even added repair of Lync, Excel and ProPlus after the install to try to avoid Office repair launching on first run of Lync. It worked for Excel but not Lync.

Based on all that, I decided to take a more drastic approach, but one that would even the playing field - I'm now removing Office 2010 and removing Office 2013 before installing Office 2013 again. I figured that would get me back to a 'clean install'. However, the Lync activation problem still persists!

I added a reboot, but same thing. As soon as Lync launches at login, the activation problem occurs, even after the reboot.

I've also tried removing Lync from startup before rebooting so it doesn't start automatically at next login. After the reboot, I waited a while and launched Excel. SAME activation issue! Interesting. This is not a Lync only problem.

I'm removing both Office 2010 and Office 2013 using the respective OffScrub scripts provided by Microsoft.

I'm totally out of ideas why I may be getting this Lync Activation issue.


Well, I can only hope this helps someone, but it turned out to be a KMS issue. We had 2 KMS servers in the environment, one with a higher priority on its DNS SRV record than the other. Somehow, this did not make Office 2013 happy. Removing one or the other allows Office 2013 activation to succeed immediately.

And the reason it looked like an Office deployment issue is that it wasn't like that before. They encountered problems with licensing, and deployed a new KMS server since the time when I first started testing my Office 2013 deployment. This is why it worked earlier while I tested clean installs, but once I got further along and tested against partial installs, the activation issue was introduced, making it look like it resulted from the different test scenarios I was now running.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.