I was trying to run status of network by following commands.

sudo systemctl status network

However the system says systemctl command not found.

  • 5
    RHEL6 isn't systemd-based, it's (sadly) the last RHEL that uses old-style SYSV init scripts. What are you trying to do? – MadHatter Dec 2 '15 at 22:45
  • Thank you for your answer! service network status worked for me! I touched /etc/hosts and /etc/sysconfig/network file and need to restart network on rhel 6.6. – DaeYoung Dec 3 '15 at 14:59
  • me trying start mongoDB worked when I was getting "systemctl not found". The following command worked: /etc/init.d/mongod start – Ehasnul Khan Jul 1 '17 at 18:26

As MadHatter has said in a comment to your question, RHEL 6 doesn't use SystemD (of which systemctl is a part), but rather use SYSV init scripts.

As said by TessellatingHeckler, the closest equivalent would be the service network status command, but it's not quite the same.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.