0

I have what I understand to be a reasonably common problem-- Apache is downloading PHP files instead of executing them.

I've used the solutions on other threads as best as I was able and learned the following:

  • The PHP file itself is fine and runs perfectly on other machines
  • The error occurs in both Chromium and Firefox, browser cache has been cleared
  • Happens both inside and outside of /var/www/
  • PHP5 is installed, up to date, is loaded into Apache, and has executing permissions
  • Apache server has been restarted after each potential solution
  • PHP5 config files enables PHP in user directories
  • I am able to use HTML files on localhost just fine, it's only PHP

The only solution I might have implemented incorrectly is the config files-- any answers regarding the configurations have pointed me to httpd.conf, while newer version of Apache seem to have multiple config files, so the specifics on which files to put Addtype commands in would be helpful.

It's also happening on another machine with Ubuntu, Apache, and PHP freshly installed, nothing else on it, so it seems unlikely that it would be anything in my machine specifically.

Version information on my machine: PHP 5.5.9-1ubuntu4.14 (cli), Server version: Apache/2.4.7 (Ubuntu), Ubuntu 14.04.3 LTS Release 14.04

Edit: Question is not a duplicate, and I have taken a look at other answers here-- as mentioned, I have tried Addtype alterations but am not quite sure where to put them due to httpd.conf being split into multiple configuration files. /etc/sysconfig/apache2 is not a valid path for me, and if that enables PHP5, PHP5 is already enabled anyway.

4