3

I've an Exchange 2013 Server with two wildcard certificates, one for matching the internal AD zone and the other one with the public domain.

The certificates are defined with those names:

*.example.com
*.local.example.com

When I try to connect through the Submission port (587) the presented certificate is the one of the zone *.local.example.com which ends complaining about the hostname mismatch of the service.

IMAP service works as expected with the correct *.example.com certificate, but SMTP don't.

Already tried things like Enable-ExchangeCertificate on Powershell to remove the SMTP service from the certificate, but it does not work.

1

Don't try and force which certificate is used. You can have multiple certificates enabled for SMTP, so set them all to be enabled for that service. The actual certificate is then set by the FQDN on the Receive Connector. Don't change the FQDN value on the Default Connector, as that will cause problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.