0

I'm using the normal blue RJ45 to DB9 cable plugged into my Cisco Catalyst 3500 series XL switch. That cable is connected to a serial-to-usb adapter that I got from Monoprice, and that is plugged into my computer (running Windows 7).

When I go into the device manager, I see that it uses COM5, so I'm trying to connect to that with putty. However, when I click "open" it just opens a black screen in putty. When I hit enter, nothing happens. I've tried looking around, but I can't figure out how to get into the switch. So far, I've tried updating the driver. Windows says it's update to date. I've tried matching the settings I see in the device manager to the settings in putty:

Bits per second: 9600
Data bits: 8
Parity: None
Stop bits: 1
Flow control: None

I've also tried changing some of those settings to see if anything would happen, but it's the same result every time. I've changed them back to as they are above.

It seems that my computer recognizes the device and the connection because of what it shows in the device manager, but it just seems to be refusing to communicate. If I try to make the connection in putty, and then unplug the cable from my computer I get an error message: "Error reading from serial device". If I unplug from the switch, or unplug the adapter, I get no error. I've also tried using a second switch (same model), and I get the same results.

  • Sounds like a bad console cable or a bad serial-to-usb adapter to me.. Unless the switch is configured for another baud rate than default. Does anything happen if you reboot the switch? – Frederik Nielsen Dec 5 '15 at 23:39
  • I've used the console cable once or twice before and it worked, and it's still very new, but the serial-to-usb adapter is brand new. I guess there could be something wrong with that. I rebooted the switch while putty was connected and it output this: TÄàd]»ÿ – duzzy Dec 5 '15 at 23:43
  • That confirms that there is something flowing. Could still be either a wrong baud rate or a bad adapter.. I would try with another adapter first – Frederik Nielsen Dec 5 '15 at 23:44
  • Okay, I'll order another adapter and see what happens. Thank you. – duzzy Dec 5 '15 at 23:55
  • Try different flow control options. – Todd Wilcox Sep 27 '18 at 1:18
0

Valid speeds (other than 9600bps) include 1200, 2400, and 4800 bps. On some platforms 19200, 38400, 57600 and 115200 bps are supported. Try these if you fail to connect. I've had this issue in the past and using a faster speed (115200 in my case) solved the problem.

| improve this answer | |
  • With each of these, the result was the same. – duzzy Dec 6 '15 at 1:42
0

Baud rate is the issue here, try and use all the baud rate above one at a time to see which one go with the baud rate configured for the switch.

| improve this answer | |
  • 1
    This is the same as the other posted answer. Did you have any new information to add? – womble Aug 25 '18 at 2:00
0

I had the same issue until I went into device manager and installed the driver for the USB to Serial cable. Then no problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.